English

Troubles with WLAN on Android 10

Hi,
I received my fairphone 3 (not +) 3 days ago and updated to the most recent version currently available (8901.3.A.0033.20200815). The newer version seems to be withdrawn because of the many additional issues.
I am currently experiencing weird WLAN-disconnects I have not found in the forum so far. Often, after I turned of WLAN and I turn it on again, it just connects, disconnects, connects, disconnects, again and again. What usually helps is to turn WLAN off and restart the phone. When turning WLAN on again, it is usually good for one switch and it is steady. If I turn WLAN off and on again, I face the same issue until I restart.
Does anyone else experience a similar issue and has a better fix?

Many regards
Grimmwolf


Additional issues with the current build, but with available forum confirmation:

  • The WLAN-Setting of 2.4/5GHz-autoselect/select disappears after selecting 2.4GHz (I tried to fix the above WLAN-issue).
  • Setting up the SDCard as internal storage causes major issues. I have two folders of Musik with about 10GB of files that are not accessible anymore and I cannot delete them, but they still consume space. The files just disappeared after a reboot even though I was able to play the music prior to the reboot. Other apps (OSMand) have no issues, others (Podcast addict) only fail for some files…

Hi and welcome,

I can relate to the wifi issue. In my case it was already there under Android 9 and didn’t go away under A10. Browsing through this forum led me to believe that it is a known issue that couldn’t be fixed by now. More or less annoying and unsatisfying…

1 Like

Did you try putting another SIM card to tedt if you receive the update this way? It may be, that your network provider didn’t release the update yet (are you on vodafone by any chance?).

Yes, this is a known isssue. It was recommended before not to format as internal storage because it could cause issues, now under android 10 it will cause issues. I don’t know whether it’s due to android 10 or to the FP3, or probably both.

1 Like

The first SIM card is Aldi-talk (e-plus), the second one is Blau (also e-plus), both prepaid without mobile data. Do the providers influence the release of updates? I never heard of this, but my retired Fairphone 1 hasn’t received updated in the past 4-5 years anyway…

Concerning the SD Card and internal storage: I really would like to use it as internal storage, because it worked fine with the Fairphone 1 and I like everything to be encrypted. I will remain stubborn for now, but I will probably have to reformat as removable at some point.

Yes they do, though I wouldn’t be able to give you details.
But for your FP1, it’s normal, there weren’t any updates for some time.

The fact that it worked in your FP1 doesn’t necessarily mean that it’s going to work in your FP3. I’m afraid you’ll have to reformat it as external storage at some point indeed.

1 Like

Hi there,

the latest version of the OS should be 8901.3.A.0045.20200905. I am now aware that it had been withdrawn.

What kind of Wi-Fi router do you have? Are there any Wi-Fi repeaters or mesh devices in your network?

For Wi-Fi it might be helpful setting 5 GHz to use a fixed lower channel.

Formatting a microSD card as internal storage is known to cause issues and definitely not recommended.

Best wishes,
Thomas

2 Likes

in addition to my previous post:
My FP3 mainly has connection problems in my home wifi. A connection to the router directly is near to impossible. I’m using a Fritz repeater as well though and using that as an access point works fine mostly.

Overall no device other than my FP3 or my partner’s FP2 have problems connecting to the router…

HI all,
Since i updated some fairphone in my job i have an issue with my AP on Wifi Meraki cisco,
All FP3 Android Version 10 reebot randomly. I tried to fix the issue to set up access point in 2,5 Ghz also 5 Ghz Radio but the issue still the same.;
I tried to open new SSID with WEP encryption but issue cannot be fix.
It’s very weird because the users told me they don’t have the issue with their wifi at home
I don’t have the issue with the FP3 who have Android version 9.
Have you some ideas to fix this problem ?
Thanks

The 0045 was never shown as possible update, but I received the October-update and it was larger than for others as far as I can tell. So I guess, I got the september updates as well.

I use a Fritzbox 7490. I connected to other routers in the mean time and there everything was fine. Now I am wondering if my password is too long on my home router, but that is just a wild guess…