Trapped in fastboot mode with locked bootloader and corrupted custom ROM

Out of interest, did you verify that your device booted before locking the bootloader? @cortomalese

Yes, I did. The whole history is: to root my new FP4 I followed this :

So I start to unlock bootloader following this:

The installation of Magisk went well and almost everything was fine for two months. I says “almost” because a bank app refuses to work, even with Magisk hide fonction, because of the unlocked bootloader.
To avoid reformatting my phone I disabled the authorization to unlock the bootloader in developpers settings. The apps bank don’t works anymore, but the phone is ok, until the last Magik’s update.
Other thing. When I tried to boot on TWRP image, I can’t wipe cache, because critical partitions was locked.
That’s when I saw that I couldn’t flash the original FP4 rom, I wanted to go back to the original state and re-lock the bootloader via fastboot flashing lock. And FP4 was blocked.
If I look at the /e/OS installation tutorial,
I see that not only the bootloader had to be unlocked fastboot flashing unlock, but also the critical partitions fastboot flashing unlock_critical, which the Fairphone manual does not say. I think that’s where my problems come from.
I think I have a point to make with Fairphone’s support: their tutorial don’t mention the need to flash critical partitions too. If “the Fairphone 4 (FP4) gives you the freedom to unlock your bootloader” it must also give us the resources to do so.

You linked to the wrong tutorial there, this is the right one:

The instructions to unlock the critical partitions are in Part 2: Unlock your bootloader under step 7:

In a Command Prompt or a terminal, type: fastboot flashing unlock_critical and press the “Enter :leftwards_arrow_with_hook:” key

To be fair, those instructions haven’t been there from the beginning and they also only added…

If after returning to Fairphone OS, your phone can not boot to it, don’t lock the bootloader. If you have any issues with booting normally please contact customer support.

…after people kept bricking their phones.

So I agree, the documentation could (and should) be improved in many ways. But at the same time this is also the prize you sometimes pay as an early adopter, “hic sunt dragones”.
Doesn’t mean Fairphone shouldn’t do everything in their power to help the community fix it (especially if it’s their documentation that’s lacking) and I don’t mean “fixing” it with a replacement device offered at full cost… :roll_eyes:


I think that’s the key point.
I assume that if you keep the authorization to unlock enabled (and you check at least once that your device can still boot after flashing the new OS) you should be safe locking it.
(and please don’t get me wrong - I don’t want to say you did something wrong and I’m really sorry for the state off your device! it’s meant for others planning to relock their bootloader…!)


I have more or less the same problem.

I wanted to try eOS, installed it according to their instructions and found it too much IPhone-like, so I wanted to go back to FairPhone OS and ran everything according to their instructions, then ended up in the Android setup process (so where you set up wifi, time, etc.) and turned off the phone and wanted to close the bootloader again to have everything as before … but then I also got this “Your device is corrupt. It can’t be trusted and will not boot.” and since then I’m stuck in the bootloader :confused:

So would I have had to go through the setup process first or do something else? But there was nothing about that in the Instruction?

I have followed the instructions for eOS and Fairphone OS, that my phone now no longer works is a bit stupid…

will write to the support also… not even 1 week after my FP4 arrived :confused:


Just for the record: I have also exactly the same problem with my few days old FP4. So it affects a pretty high number of people. The device is stuck after flashing back to stock OS and relocking the bootloader. All attempts to reopen the bootloader via fastboot commands fail. I read a bunch of support threads and I think the device is simply bricked. It should be covered by the warranty since every step followed the official guides.

I opened a ticket at the customer support on 2022-03-17 and will report when there is an answer from their end.


iodé changed their instruction to flash their OS regarding this issue
They changed, and hopefully fixed it, by copy the iodéOS custom key as a root of trust to used by the bootloader to verify rom authenticity, and permits to boot when the bootloader is relocked.

So far, nothing negative has been heard about it in the beta TG group.


Just an idea: Have you tried making booting of slot a fail by removing the battery or a hardware during boot? Maybe you can get the slot-retry-count down by that to force using slot b. I know that this requires some precise timing and trial+error.

I had the same problem it is now solved
the costs are €29.90
From the first request to support (28.02.22) until I had the Fairphone back with new software (31.03.22) only 4 weeks passed, it takes time and can be solved, unfortunately only by the support at the moment.
Just for info


Did you get your phone back fixed or did they send a new one?

1 Like

the fairphone was repaired


Have the same problem. Flashed e/os and locked the bootloader. No error appears. I used it one day but some bugs are killing the experience. The fingerprint sensor are buggy, the camera have only 12mp and the usb preferences don’t work and the usb c to 3,5 audio jack. So yesterday I decided to flash the stock ROM. Downloaded the lasted from the manual and flashed it. After booting the os run without issues. The last step is lock the bootloader. So I looked it in the fastboot. Reboot and run into the same situation. Thank for all the information guys. At least i wrote the support. The is nothing more to do…

I don’t know why something like that happen by using the official files? Maybe a wrong date in the phone? I only an android app developer and use adb the most time. But the hand full of people have the same bug. It seems to be a bigger problem that I think. I hope the Fairphone Devs find the issue.


this is more than annoying and happens not only on /e/OS, also on iodé.
There are the only two official custom ROMs at the moment.
calyx is developping their OS for the FP4, but they don’t release ist. There is one difference, calyxOS for FP4 will base on A12L not A11.
But I’m sure, if they bring it in the field and do not only test it under laboratory conditions, the users will run into the same problems. Because one of the main focus and philosopie at calyx is to lock the bootloader again.

in my opinion, what you hear lately, this is a homemade problem of firphone with the FP4
hopefully they realize it and address the matter also…
On the other hand, this will be a real nuisance for the community and for FP itself. Is not good advertising…


Yes i bought the phone with the idea of flashing other firmware special ungoogled os. So if the problem is not solved in the future the idea of the phone dies in the software part. And i won’t send every time the phone to a repair station to get the stock image flashed. I have the equipment to replace the parts and flash it myself. That’s the spirit here.


Maybe I don’t understand the topic because I haven’t read every comment here. But if you have access to fastboot, you are able to flash a (new) recovery, right? And with a recovery you can do a factory reset and flash a new ROM. How come the phone got bricked? And is this really a Fairphone issue? From the bits that I’ve read the problem is with the /e/ OS ROM, not with the Fairphone OS, which is the ROM Fairphone has control over. Is that about a correct summary and conclusion? If so, then I’ll remove this issue from this list.

You can’t flash anything if the bootloader gets locked and you can’t unlock it again if get_unlock_ability is reset to 0 (like in this case) and the system isn’t able to boot.

This isn’t a /e/ issue, similar problems have been reported for every OS, including stock FPOS. I myself am running one phone with CalyxOS right now that got get_unlock_ability reset to 0, thankfully I didn’t lock the bootloader and didn’t brick.

I’m not exactly sure who should “own” this issue, but there are Fairphones that are getting bricked and so far no one seems to have a definitive answer on what’s causing it.


and unfortunatly no statement from Fairphone so far…

They have a warning that they do not recommend locking the bootloader before the section that describes how to lock the bootloader. Imo they should add a warning on the FPOS download page, because that is where people have to go to get the required files, and if you know how to (un)lock a bootloader those instruction pages are kinda optional.

They acknowledge the problem, which is at least something


Hmmm okay. I haven’t tinkered with my Fairphone in that way yet, and probably won’t because the default ROM is fine for me. On my Pixel I can lock and unlock the bootloader from fastboot. If you lock your bootloader, but your ROM doesn’t have a properly signed ROM, then it indeed won’t work. This is the case with many, if not all, custom ROMs. The only custom ROM I know that properly signs their ROM is Graphene OS.

If this bricking doesn’t happen with the original Fairphone ROMs, but only with 3rd party ROMs, then I would say it’s not a Fairphone issue. So the question then becomes, is this issue happening only with 3rd party ROMs? Because then it’s up to the custom ROM developers to include proper secure boot support, isn’t it?

If I’m wrong then please give some examples or more details. I’m just figuring out if this one needs to be listed in that wiki topic about issues relating to the FP4. Because if it’s a 3rd party issue, it might never be fixed and then it’s just a stain in that list that will never be removed.

Several phones bricked when manually flashing FPOS, so there def is an issue not only related to Custom ROM. So I think its something every developer (FP and Custom ROM) needs to be aware off

Somehow Murena might have recognized issues