Trapped in fastboot mode with locked bootloader and corrupted custom ROM

Don’t think so. I’ve never experienced it when I was playing around a lot with locking and unlocking and I’ve read a lot of reports from users having locked the bootloader (after /e/OS installation) and getting an unbootable device but being able to unlock it again (because OEM unlock had been enabled).
I also can’t remember any report where OEM unlock was enabled and (only) locking the device changed this.
(Unfortunately I don’t have a test device atm to try it out myself.)

1 Like

Hmm apparently also did so when booting with an unlocked bootloader.

Anyway, actually locking directly after flashing without a reboot succeeded and I had a properly locked bootloader and device:

IIRC this is also how the usual installation process for other devices like the Pixel devices does it, so not that wrong.

After all, for the beta at least, you can do what I did and first boot into the system before locking, testing some things/checking everything is correct and then re-flash it and follow the steos above. That may be a good compromise, as then you’ve tested it at least somewhat.

That’s the bootloader bug we are talking about and shouldn’t happen.

I’m glad this worked for you, but I really wouldn’t recommend locking a system you haven’t booted. If you get hit by the bug (which you were) and something goes wrong, you will end up with a :brick: instead of a phone…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Yes unfortunately I guess you bricked it as many others before. The only way to get this fixed is, contactsupport and send it to the repair center. Dont accept anything more than 30€, its a bug in the system.

Will search for the most recent report and move your topic over there.

Edit @lotsofys I moved it here, its a quite long topic however the most recent I found was a German topic.

You can read here a bit and search for

get unlock ability

for further information


Hello Hirnsushi,
I am new to this forum and preparing myself to convert my brandnew FP4 to iodéOS.
In case the unfortunate happens to me (unlocked bootloader & get_unlock_ability = 0), could you tell me how to make Magisk set get_unlock_ability = 1?

Is this by installing Magisk on the yet-unbricked FP4 and applying the required commands from there? Is this correct, or can it be done from terminal-ADB?
What are the required commands?

Does the yet-unbricked FP4 need further preparations such as rooting?


See above:

(and it can be done from terminal-ADB)

Thanks Volker, now got where to find answers if required

1 Like

If you mean running it outside a normal Android userspace (e.g. through recovery), then no, your phone still needs to be fully bootable.

Oh and welcome to the community btw :wave:

Hi, i have my FP4 now for over a year and I would love to use LineageOS 20 because the FP4 is now officialy supported by LineageOS. And when I read through this topic I’m not sure if I should rly do this…
So I have to install the Lineage Recovery thing to install LineageOS. When and how do I have to (or shouldn’t I?) lock the bootloader. And if I go back to the original OS what should I do? Or is this even possible because of the Android anti rollback thing (Because LineageOS 20 is A13 and the FairphoneOS is older and probably has an older security update)
So what should I definitely not do to avoid to have a bricked phone…

And a happy new year :tada:

Just read along this topic and probably most of your questions are answered.
If it’s too long you should imho at least read the summary (which is about 50 posts…).

My very short summary would be:
you’ve to decide yourself if you’ll lock your bootloader or not. It’s a matter of convenience vs. security.
I suppose it’s not the problems of major releases but just of date of security patch level.
And as long as OEM unlock is enabled you’re on the safe side.

1 Like

So if I don’t lock the Bootloader, I’m on the safe site?
With other words I can let the Bootloader unlocked and if I would go back to FairphoneOS I can just lock it?

No especially when you go back to FPOS you have to be careful. Did you read as suggested?


The tldr is: it’s fine to relock if you use the device flasher by CalyxOS. If you don’t there is a small risk of the phone bricking, which I personally wouldn’t risk.

If you make sure the setting mentioned above is showing unlocking is possible you’re probably fine.

IF you choose to leave it unlocked you ultimately risk almost nothing.

So in combination with the answer from yvmuell

Did I understand it right, that it doesn’t matter if I lock it or not when it comes to get a bricked phone? The risky part is to install later the FPOS?

For what exactly do I have to lock for? I read quite a bit of the Topic and I didn’t find like the cause of the bricked phones. What does the get_unlock_ability exactly mean? And what should I do when it is 0 or 1?

For your future risk of bricking the phone it doesn’t matter if you’ve locked it in the past, that’s correct.
But, the risk isn’t only present with FPOS, you can brick it with any OS you install if something goes wrong and you didn’t make sure fastboot flashing get_unlock_ability_ is 1 beforehand.
The CalyxOS device flasher just checks that for you and stops if it isn’t, that’s the part that makes it safer.

You don’t have to, there are some (banking) apps that check for that and will refuse to work and there are several security benefits that are only in effect if the bootloader is locked.

Whether you can unlock the bootloader again by issuing fastboot flashing unlock or not (which means it’s bricked if you can’t boot into the proper Android userland)

If it’s 0 don’t lock, reflash the ROM you were trying to install, check again. If you want to lock the bootloader, don’t boot into Android userland after flashing, there’s a high likelyhood that resets the value and you definitely shouldn’t lock after that.


Thank you so much for your detailed answer and sorry i’m still asking (maybe stupid) questions.

So let’s go through an installation:

  1. I have to install the Lineage recovery (Does it matter already here if the unlock ability is 0 or 1?)
  2. Let’s say I can install the image and it says 0 should I flash it again? If it is 1 can I run fastboot flashing lock and boot into LineageOS and I’m still able to go later back to FPOS?

And now worst case: I brick somehow my phone… Did I understand it right that I would have to contact the support and then it would cost me 30 Euros to fix it or would that mean my phone is broken?

LineageOS doesn’t support a locked bootloader, so you definitely shouldn’t try to lock it when using that.

If you want to go back to FPOS it’s safest not to relock the bootloader at all.

If I were you, I’d use the CalyxOS device flasher. It does everything for you, more or less. Just follow the instructions carefully and you’ll be fine.

1 Like

As long as you don’t brick your phone you can always go back to FPOS, but as @AvidAlbatross noted, make sure, if you are locking the bootloader on a custom ROM, that that’s actually supported.

That’s generally what happens, since it’s a bug in the bootloader so Fairphone’s responsibility, but none of us work there, we can’t guarantee it, the policy might change any time.

Just a small addendum, if you decide to go that route and updated your phone to the latest FPOS already, you’ll need to use the beta factory images, not the ones mentioned in the instructions. More info here.

1 Like