Touchscreen stops working after a few minutes


For the last few days, I’m having issues with my screen. A week or so ago, 2 or 3 times, my screen did not turn on again, and I had to take out the battery to start it again. It worked.

This morning, at some point I tried to turn on the screen to unlock the phone. While the screen did turn on instantly (the button works), it did not respond to touch. I took the phone apart, screwed everything back tightly, started the phone again. It works normally for a few minutes, time to start writing a text or make a short call. But after a few minutes, the UI seems to restart, or sometimes the screen goes dark. And the touch doesn’t work again. Tried the whole process 10 times in a row now, same happens every time. The phone is not usable anymore.

One other thing I noticed: when I turn the screen on now, at first, for a few seconds, the battery charge status on the lockscreen shows “%1d%%”, before changing to the actual charge. But the touch still doesn’t work.

Any idea what to do?

The problem might be correlated with the latest update, but I’m not certain of that. Could it be a software problem? In which case, how can I revert to the previous version of the OS?

Thanks for your help.


I tried booting in Safe Mode. It actually solved the problem. So it had to be a software problem.

No idea what the origin can be, but I reset the factory settings of the phones and it seems to work all fine now.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.