Touchscreen doesn't respond

A couple of weeks ago my touchscreen stopped reacting. The phone had been in my jacket pocket all day but I hadn’t used it or done anything with it. I tried taking the battery out and restarting but it still doesn’t work. I can therefore no longer acces my phone. I looked on the forum but couldn’t find a solution. I’ve also contacted FP support (request #89166) but have not heard back (apart from a confirmation that my email was received). I want to know whether there’s anything else I can try before doing a hard reboot and losing all my settings. Thanks

Do I understand you correctly that your screen is not black, but still shows the launcher, but you can’t tap anything?

Or is the screen black too and if so does the led light, e.g. if connected to the charger?

You understand correctly. The screen is not black and shows all the apps and so on, it just doesn’t respond.

You could connect a mouse via USB OTG cable in order to backup all your data an settings (e.g. with Titanium Backup).

1 Like

I’m not sure how to do this. I have Titanium backup on my phone but how would I access it with a mouse?

You can controll your screen with the mouse pointer like you controll a PC. Left click = tap. So you can use all your programs more or less normally.

Thanks. I’ll give it a go.

Have a look here:

Thanks - never hear of a OTG cable before.

I just borrowed an OTG cable from a friend (it cost him only 3 €), plugged the mouse in and it works fine. I can open apps and use them, and swipe by holding the left key and drag. The only thing I haven’t found out is how to leave apps, because the FP1 has hardware buttons. Well, in the worst case this could be done by rebooting.

There are probably apps that can add software buttons.
Alternatively: USB-OTG->usb hub -> mouse + keyboard.

For example this app can add software buttons
I just installed it on my FP1, works great!

I have the same problem. Screen doesn’t react on any input.

Taking the battery out and reboot it worked sometimes, but afterwards it never works for more than some ours before going back to nonresponding again.
Yesterday, after it hadn’t worked for days, i gritted my teeth and went with a factory reset, which wiorked- but again, just for a handful of hours, just now the screen went to nonresponding again. Is there any actual solution for this? I haven’t found one in this thread or any other.

Please do the #touchscreentest . You’ll also find follow-up steps according to the outcome of the test.

Would love to, but can’t follow the instructions properly, since
CTP-Test (“Press power to select CTP Test”) is an option not present in
the touch panel section of the factory mode in my Phone (FP1).
I can only choose between Calibration, RTP Linearity, RTP Accuracy, Sensitivity, Deadzone, FreeMode, Test Pass and Test Fail.

Are you on the latest version of Fairphone OS? Your Fairphone Updater App should say “Fairphone OS 1.8.7”. Try to get to the Updater App (it seems that your touchscreen does work sometimes) and find out, please. :slight_smile:

Got it to work one more time- yes, my OS is 1.8.7.

Il m’est arrivé la même chose hier. Pas d’accès à l’écran tactile… d’abord en pointillé : de temps en temps cela fonctionnait et souvent non, je ne pouvais pas répondre aux appels téléphoniques. J’ai éteint et rallumé mais impossible de taper mon code alors que l’écran était allumé, mes appels téléphoniques reçus s’affichaient sans que je puisse rien faire. Finalement j’ai à nouveau éteint, démonté la batterie, la carte SIM (ne serait-ce que pour l’utiliser sur un autre téléphone). J’ai remonté, laissé éteint et attendu. Hier soir;… cela fonctionnait de nouveau et aujourd’hui aussi… mystère !

A post was merged into an existing topic: Fairphone 2 unusable while charging