TomTomGo app not working fully anymore on FP1U

About three weeks ago the services of the TomTomGo app stopped working on my FP1U.

For these services (traffic info and radartrap database) an internetconnection is needed.
The FP1U 3G connection works just fine, so that`s not it.
It appears the app just cannot connect to the internet anymore.

App and FP1U are fully updated,
I have not changed any settings whatsoever.
Navigation still works fine, GPS-signal available etc.

I tried the solutions mentioned in the TomTom-forum : no results.
Of course I am already in contact with TomTom customerservice : they are looking into it.
Even volunteered to be a guineapig for their new updates. :wink:

So, does anybody have similar experiences and a solution perhaps ?


did the TomTom App work before the last app update?
Maybe the TomTom team can provide the previous version (or you have a backup) and you can try this one.

I would go to the app settings and clean the “app cache”, if that does not work, un-install and re-install the app (make sure that you have your account data and a uptodate backup of your maps etc.).

FP1U runs with “Jellybean” Android 4.2.2 (Kitkat is hopefully coming soon), so maybe the current TomTom app does not support this android version anymore.

Thanks for the constructive thoughts !

It worked just fine 2 app-updates ago.
Unfortunately the app doesn`t work when an update is available… it forces one to run the latest update.

Didn`t think of clearing cache, tried it : no change. :tired_face:

I checked their website : the app requires Android 4.0.3 or higher to function.
Thus 4.2.2 like on the FP1 is fine.

On edit : didn`t try re-installing the app yet.
On the TomTom-forum some people tried it and had no results.
Will try tomorrow.

So you are not they only having this issue? Can you post a link to the topic on the TomTom forum?

Sure, see below.
To be clear : no Fairphones are mentioned in that topic .

Update : I wiped and re-installed the app… no change.


Won’t help you, but no issues here.

Sometimes it can happen that versions are marked to be ready for a specific Android version but they are not (e.g. if ths developer uses certain libraries).

Maybe this happened with the TomTom app as well?

You wrote that they enforce the update to the newer version. Did the previous version work or did they change the api to get new data?

If the old version works you could try to run this version. Do you have a backup?
Some older version apps are still available on alternative appstores
:warning: be very careful installing apps from these stores. Some contain malware and other dangerous!

You could try to contact the developer to get the previous working version

ApkMirror still has version 1.10 of the app.

(Apkmirror is widely trusted because they are maintained by Android Police. I myself use it sometimes.)

I can only repeat that I’ve never had any issues with TomTom on my FP1; and I accepted all the updates (app + map).

Running the old version won`t work : updates are forced. :cry:

And yes, the old versions worked for 2 years, fully functional.

@werner_noebauer : could you expand a bit on API ?
I think I checked, al little help would be usefull tough.

Furtermore : becoming a betatester is taking a bit more time.
I dont read my gmailaccount, thats were they sent the details…

I`ll keep you guys posted.

Hi Friedrich,

by API I meant “application programming interface” (

If the interface changes and is not compatible to older versions the result maybe problems with the data transfer.

Usually developers create new apis or make them downward compatible.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.