TextSecure - I don't get notified of new incoming messages after having upgraded to Fairphone OS 1.8.5 today

Dear all,

I’m a happy user of the messaging app TextSecure. After updating Fairphone OS to 1.8.5 today I don’t receive notifications of incoming messages anymore! Which is a bummer.

To clarify, once I open the app my phone vibrates, a sound alarm rings off etc. and I can properly read and write push messages via TextSecure; there’s is no problem with the encryption, a topic that has been brought up before.
The behavior experienced suggests, at least to a techno-doofus like me, that the phone interacts with the TextSecure servers only when the app is actively opened, and not when it runs quietly in the background, am I wrong?

I think TextSecure uses Google Cloud Messaging - could it be that the OS update’s interaction with GCM causes trouble?

Do the other TextSecure users in our community experience these problems, too?

Very quick answer now, maybe more tomowwrow, if necessary: yep, seems to bee a GCM issue. I assume your WiFi symbol is still grey? And I take it you restored from a backup?

In Threema, there’s an option to renew your GCM-related settings; I thought there would be soemthing like a “renew” option in TextSecure as well - alas, I can’t find it on the fly.

Also, have a look in this thread here, also on how to check if you are connected to GCM.

One workaround might be to restore your android ID from the backup (if your backup solution allows this), since it often changes after a wipe/factory reset, and definetly after a HW change.

1 Like

Please make sure that

  • you successfully re-installed the Google stuff after the update
  • your Google account is present under Settings -> Accounts (not sure about this one, does one need an account for GCM?).

Then try re-registering with the TextSecure servers by disabling and enabling “TextSecure messages” (TS Settings -> Advanced).
This won’t delete your key material, so you don’t have to worry about your contacts getting “Unknown identity key” warnings.

1 Like

Thanks for the quick reply!

The WiFi symbol is not grey; it’s the usual blue. I’m not sure which backup you have in mind. I did not backup my TextSecure messages, if that’s what you’re referring to? Neither did I backup my phone’s apps and the like…

Wrt your link, I have not dared to install XPosed, GravitBox etc. sofar, but if that’s what it takes…

Wrt to you last paragraph, again, I’m not sure what backup you’re refering to…

Thanks Generaldirektor!

My Google installation was successful and I have reregistered. Now I’m waiting for incoming messages. I’ll let you know whether it helped.

I’ve had trouble with my keys in the past after hard resets, OS updates etc., and reregistering always was the solution. But never did I suddenly experience problems with GCM; that’s why I didn’t come up with your idea myself in the current situation. I hope you’re right and reregistering helps.

1 Like

Ich schick dir jeden Tach Cäsh, im Koffer!

Send me a PM with your number if you want me to send a test message!

1 Like

OK, once again reregistering seems to have done the trick!

I take it once and for all: Should you ever face problems between your Fairphone and TextSecure (you updated the OS; you dropped the phone in the loo etc.), reregister for push messages!

Thanks, @haffenloher and @humorkritik!


Don’t worry - I think my trouble came from installing XPrivacy. I’ll update that thread after my 1.8.5 update with news if I am connected to GCM again - didn’t dare to update yet it because I’ve got not much time on my hands ATM, just in case if something goes wrong. :smile:

Whoa. That’s something I wouldn’t dare. I learned the hard way: Thou Shalt Always Have Multiple Backups.

Well, to elaborate on what I meant: your device has an ID registered with GCM. When you update, wipe, or replace your device, Android (or GCM?) assigns you a new ID. From a proper backup, you can restore this ID.

However, in most apps relying on push services, you can also use a “refresh GCM services ID” or something like that - and that’s what you did by un-ticking and re-enabling TextSecure messages. TS will have warned you that you un-register the app from the (GCM) server, and re-ticking it of course registers your new ID.

I conclude: the case is solved. \o/

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.