Switching between two different FP-Open-Versions or alternativ FPOS- hiding data from Google

In the sense that Google will transfer the contacts to their servers without your noticing that they did it?

Background of my question is: I use Lineage OS with opengapps pico and my contacts are stored in my personal owncloud. And I just checked: they don’t appear in my Google account under “Contacts”.

Even back when I was on my Fairphone 1 I already had the contacts in my owncloud and had the google apps installed on my FP1.

Edit: but of course I don’t know what happens if the contacts were stored on the phone and the Google apps are installed later

At least back when I used Open GApps, the syncing to Google was enabled by default, so one of the first things to do after installing Open GApps was to disable syncing for the Google account.

No, I meant only Step 5 in Level 5. You can ignore the rest :slight_smile:

1 Like

Threema does not send the message content over Google Cloud messaging. They only send a empty message for that the Threema client polls the message from Threema server. Also the notification now goes via FCM, no longer GCM (don’t know if this is still beta or already the production version).

Referring: https://threema.ch/de/faq/privacy_push


Hello Stanzi,
do you know LinageOS with MicroG?
See here: https://lineage.microg.org/#instructions
With it you don’t need to give up root and you have MicroG - that is location services without Google.
And you can save your contacts locally on the phone and disable syncing with Google. I am using it for almost 2 years now and non of my contacts is on Google (and off course not on Facebook).
In my opinion your ideas are not really practicable and will lead to data loss soon.
But I do not use car sharing or Scooter or drone apps. Therefore I do not know if these will work.
But I expect that they will work with LinageOS with MicroG.

1 Like

Ok, Stanzi, thank you!
That helped and so I installed MicroG courageously as described in Paula’s Wiki Level 5, Step 5.
I let fdroid open the microG F-Droid repo in the MicroG download section and installed it.
After that I installed microG Services Core and the other components as described in the wiki, also two Nlp Backends and rebooted.

After that at least two apps crashed (FritzFon and MyPhoneExplorer).

My MicroG now looks like that:

The invisible first Line is: “Konto Google Konto hinzufügen”

The self-check results in:

Which is not the intended result that the wiki should lead to.

Edit: ooops, the Whole screenshot ist very long and only gets visible, when you click it…

Do I have to login to a real google-account now?
Or did I make some mistake?

Yep, it’s not. You also have to install an XPosed module called “FakeStore” to get the missing checkmarks. You don’t have to sign in at all. Btw, you can remove the DroidGuard Helper app and deactivate Geräteregistrierung, Cloud Messaging and SafetyNet, since most apps don’t require them :slight_smile:

1 Like

You also have to install an XPosed module called “FakeStore” to get the missing checkmarks.

Yes, as the wiki said and I’ve done that. It looks like that:

It’s the second one that I installed. Looks like a MicroG app.
Do I have to install exposed?:flushed:

Sorry, I meant the other one, FakeGApps. And for that you need XPosed. But that’s actually a good thing since there are many useful XPosed modules, e.g. XPrivacy, which lets you control permissions from apps much better than the built-in method.

1 Like

Thanks, @Stanzi. I installed as you recommendet although I actually never wanted to modify my FPOpen because afaik regular updates won’t work any more and need reinstalls of certain components.

BUT: I am glad about your hints because now I got a few apps running that I couldn’t have before without GMS. That’s great! :smiley:

Except car2go which is mentioned as a “Problem App” on https://github.com/microg/android_packages_apps_GmsCore/wiki/Problem-Apps

So I’m very grateful about what I learned and about having apps running that I missed a long time!!!
Thanks again!

Thanks for your hint. Yes, I’m aware.
And therefore I once used a hack for TWRP that also backed up my data in the internal storage but the restore failed:unamused: So I won’t use that again.


Thanks, @Amber for the clarification. Threema is just a clever app- I like it!


I’m afraid I can’t answer your questions - but glad others already did. But can you tell me where you get the car-sharing apps (the ones that don’t work) from? I have a FP2 with FP-Open installed and use Yalp to get apps that are not available from F-Droid. The car sharing apps I would like to use - Sharoo and Mobility (both Swiss) don’t appear there and I’ve never understood why.
Thank you!

Try with Aurora store. Yalp seems not to be up to date right now.

Hi @Linda_CH,
Yalp is my apk source too but it is annoying me seriously since a few months because it seems to be outdated and doesn’t show apps that exist definitly.
This morning (!) I found this.

There it says:

Wenn man derzeit bei Yalp in der Suche “firefox” eingibt, findet Yalp nichts.
Man muss also im Browser auf “https://play.google.com/store/apps” gehen, dort in die Suche “firefox” eingeben. Dann findet man welche. Dann klickt man den richtigen an, und kopiert aus der Adresszeile das hinter dem "id=“ ohne das was eventuell noch dahinter mit dem fragezeichen steht, also bei firefox das “org.mozilla.firefox”. Das fügt man bei Yalp in die Suche ein, dann ‘findet’ Yalp die App.

I’ve just tried with sharoo and voilà: it’s found! But Yalp declares my FP2 as not beeing compatible. Maybe because of my German IP.
Can you get it run?

If I got that right Aurora is a fork of Yalp and doesn’t work neither on my phone because it says it has no “network connection”.

Merci, Chrisse! J’avais déjà essayé, en fait, et c’était pareil. J’ai réinstallé Aurora hier et maintenant, j’y trouve Mobility mais pas Sharoo.

Aurora seems to feature Mobility but Sharoo doesn’t appear there either. I had installed it from Yalp previously, actually, but it seems to have disappeared from my phone (unless I uninstalled it but I cannot remember doing that) and from Yalp aswell.

Can anyone tell me whether Mobility relies on GSF? Will it work with FP Open, without MicroG?

Still wondering what happened to Sharoo… Can companies have their apps banned from Yalp/Aurora simply because they don’t want them distributed there?

Thank you! That actually worked! But Yalp also tells me that “my device isn’t compatible with this version”. No further explanation - the app doesn’t even seem to use GSF. Could it be because we don’t have the newest version of Android?.. Wie auch immer… My partner just got a brand new phone, I’ll let him install it - I don’t like driving anyway…

There is something weird in Aurora with Sharoo: when I search for it, it shows but disappears instantly. If I search again directly afterwords, it shows and I can install it. Try to search 2 times in a row. You can also try to push on the magnifying glass or on the name “sharoo” when it appears on the short-list. It shows on my phone, it should on yours too!

That happened to me with Mobility (appeared briefly, then disappeared) til I deactivated all the filters in Aurora… Without filters, Aurora finds Mobility. It still doesn’t show me Sharoo. But Kle gave me another method for Yalp in this forum, which seems to work for sharoo… (see above)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.