"switch to mobile data automatically" not available?

I’m having issues with my wifi at home (keeps kicking me off) and I don’t want to accidentally watch GBs of data over LTE unknowingly.

When I search for the option “switch to mobile data automatically” in Settings using the search function, it’s listed, but when I click on it, it doesn’t get shown. Is it not available anymore?

Turning off mobile data when you don’t want to switch to it should be sufficient? You can easily do so by tapping the mobile network symbol in the pull-down menu just like you enable/disable wifi.

2 Likes

No luck getting Wi-Fi to work? There were some issues initially with the Fairphone 3, but most of that could be resolved with an OS update or certain router settings somehow, I think … https://forum.fairphone.com/search?q=fp3%20wifi

1 Like

Switching the router to a lower-frequency channel seemed to eliminate most of the cut-outs.

Of course that’s only a solution at home; I still have the issue in other wifi hotspots.

This is the workaround I’ve been using.

It is rather inconvenient, however, since I frequently forget to turn mobile data back on when I leave the house and miss messages. If the more convenient capability is there, I’d like to use it.

Hi arizondeux,

i think you have to activate the setting “Activate Wi-Fi automatically” for that setting to appear. Only then Android 9 knows when to use Wi-Fi or mobile data.

Although i would advise you to set up a data tariff in the mobile data settings. That should help in the future not going over the limitation. Maybe also activating the data saver setting. :slight_smile:

Feel free to ask if anything is unclear.

Greetings,
JuengerJesu

Thanks for the tip! I tried it out immediately: no success. The option still shows up in search, but isn’t there when I click on the search result. I also tried turning off dev options in case something was interfering, and of course restarted the phone. No cigar.

Do you (or anyone else reading) have access to the setting?
(just to see if perhaps something else in my constellation of settings somehow disables it)

In the developper options I found an setting called Mobile data always active. Don’t know if it can help you though but seeing the descritpion it’s worth a try. (It’s on by default)