Super slow (or non-existant) connectivity

Hello, i’m slowly getting used to my new phone but am disappointed with the connectivity. I’ve made sure the APN details are correct so it’s not that but often the 3g data connection is super slow or doesnt work at all. Is it just generally pretty slow and this is what I should expect or do I have an issue?

Thanks

In which country do you live and who is your provider?

I’m in the UK using giffgaff

@Chris_R wrote:To make sure you data connection is enabled, go to Settings > More > Mobile Networks > Data Connection and make sure your SIM is selected.

Also ensure the 3G service is confirgured for your SIM by going to Settings > More > Mobile Networks > 3G Service > Enable 3G and make sure your SIM is selected

@Chris_R is as far as I know also using giffgaff, perhaps you can check your settings with him.

Thanks yeah all of those settings were correct. I saw that guys posts but
his APN settings were wrong and once he updated them it was resolved…

10 mins and page still not loading!!

Got some questions to try and see if we can figure out what’s behind your issue…

  • Can you confirm you are you using these APN settings?

  • What type of signal are you receiving? You can tell this from the letter to the top left of your signal - if you are getting G this is the GPRS network aka 2G, if you have E this is the 2.5g network aka Edge, if you are getting 3g then you’re on the 3G network and if you are getting H or H+ you are on the HSPA version running on the 3G network. Each of these runs at different speeds, so if you’re not getting 3g or H(+) then web pages will be slow.

  • If it’s not the signal, is other data network traffic slow - so is it just internet pages that are slow, or can you for instance use the Facebook app (if you’ve got it and use it) working ok and how about email?

  • If it’s just the internet, which browser are you using - just the default one or another one you have downloaded?

Thanks a lot :slight_smile:

I’ve changed the APN settings - although the only ones that were wrong were
for MMS so that shouldnt affect data connectivity right? Before I did that
the signal was showing as E now there’s no letter at all.

It’s mainly the internet browser that’s slow - on both the default browser
and firefox that I’ve downloaded. Often there is no connection for the
gmail app but the FB app seems to be ok…

The MMS settings shouldn’t stop the data part working. I have all my APN settings in one rather than having a different one for internet and MMS but even that shouldn’t present a problem.

Ok, so if you’re on the Edge network (E) then that’ll be why. You get about 400-500kbits per second on the Edge network. It’s good enough for very simple browsing or getting simple text based data in apps, but it’s not sufficient for proper web browsing.

You can check what signal quality you ‘should’ get here, it might be that a signal booster like the kind that some operators provide would be helpful - but I’ve never used one so I don’t know for sure.

RE getting your signal back, try turning off and then turning back on your signal (either/deactivate activate airplane mode or go to settings SIM management and turn off and then on your SIM.

Thanks again. I’m trying to take a screen shot to show the APN settings as
there are some I have that you haven’t mentioned but can’t figure out how
to!

How come I’m on Edge? Is that the network where I live? And can I sort it?

Also turning off and back on hasn’t helped I have no data connection or
letter at all for my giffgaff sim…

Also checked the coverage checker and says its good inside and out full
signal.

Here’s the screenshots…

Apologies I’ve taken a while to get back to you.

Do you still have the problem - and is it only when you’re at home, or is it the same wherever you are?

A couple of minor tweaks you can make to see if it makes any difference in the APN settings

  • First the APN type, tick all the available options - at the moment it’s only got mms which is your picture messaging)
  • Next take 8080 out of the Port setting (leave 8080 in the MMS port option)
  • Save that and then try it.

If you’re still having trouble, you could try and see if you could select the network manually - I’ve just done this for my work’s EE network to get from 2G to 3G. To do this go to Settings > More > Mobile Networks > Network Operators > Choose your giffgaff SIM > Select Manually > OK any messages > Select O2 - UK

OK brilliant that helped a lot I now have signal but it’s veering wildly
from E to H to H+ and back to being super super slow again… Anything else
I can try and any reason why it won’t stay on one signal even if I haven’t
moved a muscle? Really appreciate the help :slight_smile:

Hi Chris,
I seem to be having similar problems. When you say tick all available options on APN type what do you mean, as it requires you to type these in manually, and mms is what is suggested?

Rob

Here you can find the APN settings for Giffgaff: https://community.giffgaff.com/t5/Settings-for-your-device/Internet-and-MMS-settings-APN-guide/ta-p/3489121#faq_no_1.