Stuck with locked critical and FPOS

I’ve been running iodé since I got my FP4. Yesterday I wanted to go back to FPOS, so I installed the FPOS firmware and then I read on the forum about the bug that the FP team is ignoring.

I got the sad news get_unlock_ability: 0, but I did also read that it might work to reflash FPOS firmware again and then lock the bootloader before reboot, but when i tried to reflash FPOS I got a red error saying that I have to plug the battery and then try again, but whatever I did I couldn’t get past that message. Somewhere in this mess I locked the critical partition.
fastboot oem device-info gives:

(bootloader) Verity mode: false
(bootloader) Device unlocked: true
(bootloader) Device critical unlocked: false
(bootloader) Charger screen enabled: false

and fastboot flashing unlock_critical gives:

FAILED (remote: 'Flashing Unlock is not allowed
fastboot: error: Command failed

So now im stuck with a unlocked bootloader with the critical partition locked and I can’t flash anything with the critical partition locked. Is there any way out of this mess? I’ve been looking in the forums but I can’t find anyone with this exact problem.

And yes, the OEM toggle is greyed out.

Are you sure the installation of Iode OS requires critical to be unlocked?

Did you try to change the slot?

Btw the toogle is greyed out because your bootloader is unlocked.what is the output of get unlock ability?

Welcome to the community :wave:

Two questions:

  • Did you issue the fastboot flashing unlock_critical command with the phone in fastbootd mode instead of fastboot by any chance
  • Are you still able to boot into FPOS?

If you can still boot the system, we can reset the OEM toggle with Magisk.

@Lidwien can we somehow unmerge those topics again, they aren’t really related.

1 Like

Just did it at your request.

1 Like

The only thing I can remember is that I installed it like the iodé install instructions said. Looking at those now i can see that it even say not to unlock critical partition. This makes me confused.

I have no issues with booting up FPOS right now. I would like to be able to reflash FPOS tho. I’ve tried change slot, but there’s no difference.

get_unlock_ability: 0, so that is not strange at all. I just wanted to mention it.

Yes, I did, here’s what I got in fastbootd

FAILED (remote: 'Unrecognized command flashing unlock_critical')
fastboot: error: Command failed


Would it help me to unlock the critical partition if I could reset the toggle?

I meant, did you try it in regular fastboot :slightly_smiling_face:

If the ability to unlock the critical partitions is tied to OEM unlocking being enabled, and that seems to be the case, changing that switch back to on should help, yes.

Oh, sorry. I read your comment in the wrong way. I executed the unlock command in the screen that pops up when I do a adb reboot bootloader.

I don’t really know what to expect here, but I now have a rooted device. The OEM-setting is still greyed out. I though something like fastboot oem unlock would work, but it seems like it’s not a valid command.

Alright, then all that’s left to do is:

Reboot to bootloader afterwards and check if you can unlock the critical partitions.

1 Like

Wow, that worked. Thanks for spending time helping me solve this.

Now I have get_unlock_ability: 1, is this because of enable the toggle? I guess it might be a bad idea to lock the bootloader now?

Edit: Now I’ve successfully flashed CalyxOS and locked the bootloader. I’m very satisfied with this. Thanks a lot!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.