Stuck optimizing apps after updating on FP Open OS 16.07.1

After updating to FP Open OS 16.07.1 (running with GAPPS), my phone is stuck “optimizing apps” over and over.
My phone is encrypted & succesfully booted after the update & even displayed the homescreen correctly.
Then, it suddenly rebooted to optimize apps and got stuck in an infinite loop there.

I disconnected the charger and wiped the cache, as suggested here but to no avail as my phone is encrypted and TWRP is Version

Is there any solution for this apart from factory reset?
And is the current version of TWRP included in the update to FP Open 16.07.1 so if this happens again I can at least backup (which, obviously I should’ve done before, but I thought meh - just some minor security updates. . .)

Thanks for your help!

Did you have Gapps installed?
Then download the latest version on your SD card and install it again via TWRP.


I did have Gapps installed & thanks for the prompt reply!
I don’t have an SD card on me right now, but I will try this evening and let you know if it worked.

Thanks again

1 Like

Worked like a charm :slight_smile:
Thank’s a lot!!!


Maybe it will help others to post a GAPPS version number (>=) that works well with 16.07.1?


For future reference:



I just installed the same version as I had before:
Platform: ARM
Android: 5.1
Variant: Pico

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.