Stuck onto Team Win Recovery Project after trying to update my phone

Hello everybody,
I am sorry if this post comes in addition to lots of other posts regarding that topic… But I’m feeling helpless right now.

  1. I have tried to download and install the last fairphone update.
  2. I followed the instructions given beforehand to free the needed space in my phone.
  3. I downloaded the update… at first, nothing happened after the downloading… but after 3 or 4 attempts (don’t remember exactly), I ended up into the TWRP menu.
  4. I have read several posts on this topic…and I think I have tried the main and easiest options :
    _Removing the battery and re-starting the phone → no effect.
    _Turning off the phone while pressing the ´volume down’ button → no effect.
    _Going through ´Install’, cache, fp…zip (don’t remember the exact formula) → no effect.

Now, I would like to be sure :
Are there any other options than…
_Installing the update manually (which could prove tricky since my fairphone has never been recognized by my computer) ?
_Restoring (or rebooting ?) the phone to factory settings ?

I thank you in advance for your upcoming answers !

I’d still try to go this way.
A factory reset will probably not help in this case.
Did you try to connect FP2 and computer using an USB data cable? If yes, it might be a driver problem. What OS is your computer running? You may search for solutions of driver problems in this forum.
Or you try to contact a #fairphoneangel if there’s one near you.
(If you by chance own a raspberry pi and have an USB data cable then this might help: Raspberry Pi based flashing station? )

1 Like

Thanks !
I’m going to try this, although I have no idea about what a USB data cable is…lol

See e.g. here:

1 Like

Excellent. I’ve learned something. Thx !

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.