Stuck on first screen - help appreciated!

Hi, I’m stuck, and would appreciate advice!
Firstly, the phone sent error messages saying various apps not working - facebook, messenger, google play etc. I think I clicked the report problem button for google play.
Then got stuck in start mode - dark screen with Fairphone coming up, looking like it was booting up.
Consulted forums, so
checked buttons
removed battery
then pressed onoff button at same time as increase volume
got to team win recovery project.
when I try reboot or restore it says no OS, are you sure?
Having read some more topics, I tried rebooting anyway.
Still in the same position, so when I put the battery back, and turn the phone on, I get a black screen and Fairphone, and it buzzes and tries again a few times.
The only way to turn it off now is to take out the battery.
Any suggestions?

I think we need more information to help you:

  • What was the last thing you did when it was still working?
  • Which operating system are you running? The standard Android from Fairphone or the Open version or Lineage OS?
  • Do you have a backup? / Is reinstalling an option?

Thank you. I had turned it on and tried to check messages and facebook. It came up with multiple error messages, as above. This was first thing in the morning. I don’t remember doing anything other than messaging etc the previous evening.
I use the phone as it came, so I assume it’s the standard Android from Fairphone.
I am reconciled to reinstalling if necessary.

So, we’re free to try stuff :slight_smile: .

Do you have an SD card in the phone, and when Android asked you, did you choose to incorporate it into Internal Storage (as opposed to keeping it as external storage)?

If so, the SD card somehow becoming corrupt might cause all kinds of trouble.
I have no experience with this setup, but perhaps it might be worth a try to

  1. take the SD card out and put it in again, then try to boot.
  2. in case that didn’t help, take the SD card out and try to boot without it?

You can force a reboot by pressing the power button for approximately 15 seconds.

If you boot into the TWRP recovery by pressing Volume + while rebooting, one of the options in TWRP’s Reboot menu is Power Off.

I don’t have an SD card. Happy to try whatever is necessary to get it to work again.
I’ll try what you suggest with TWRP to turn off.

Well, in that case …

Boot into TWRP - Wipe - Swipe to Factory Reset

Try to boot afterwards. If it still fails …

Now, the TWRP opening screen is just flashing on approx every five seconds - screen visible for a moment, not long enough to read it.

OK, this sounds like hardware now.

You could disassemble and reassemble the modules, perhaps cleaning the contacts with alcohol in the process.
Here’s a nice video about disassembling and reassembling all the Fairphone 2 modules, you are allowed to do that without losing warranty

In case that doesn’t help …
If you happen to have #fairphoneangels in your vicinity they could perhaps help to identify a malfunctioning module by swapping modules.

Then there’s still #contactsupport.

Thank you. I shall have a look at that. If I don’t get anywhere, it is still under warranty.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.