Stuck in Team Win Recovery Project

Hi, I tried to install an update a few days ago and have been stuck in Team Win Recovery Project ever since. I have followed every piece of advice and suggestion here but no luck. I’ve tried everything multiple times and it’s getting frustrating! Are there any more ideas out there? Can anyone help? Thank you!

It’s hard to give you advice you haven’t tried yet if you don’t tell us what you tried.

First I’d try to Reboot > System in TWRP.
If that just reboots back into TWRP without an error message I’d turn off the phone, take out the battery, press the power and volume buttons a few times, take off the rim of the cover (or the whole cover if you have the old cover), put the battery back in and try booting again -> In other words: check if it could be something with the buttons.
If it still just boots into TWRP I’d try reinstalling the OS manually.


Sorry, I should probably have put this request in an old thread, my fault. I have tried what you suggest multiple times, I’ll try it again. I can try reinstalling manually but my laptop is not registering the phone when I connect via a lead. And I’ve tried lots of different leads. I’m not techy but desperate to try anything! Thank you for your help.

I don’t know what you expect when you say “registering”, but the manual install method uses the phone booted into fastboot mode, this way you will not see the phone in a file explorer or anything fancy like that.
Just follow the instructions @paulakreuzer linked to thoroughly.

1 Like

Thank you for the reply. You can see I don’t know what I’m doing and don’t get the terminology right! I could not follow the instructions for installing the OS manually as there was an error message when I tried. I did manage to download the files to my laptop but then I could go no further. I followed the instructions exactly. I have also tried a factory reset, following the instructions on the Fairphone website. Still keeps taking me back to TWRP. I appreciate everyone trying to help.

You might try to search for #fairphoneangels near you…


Ok, here’s a detailed guide including screenshots how to install the phone from scratch.
If something in this guide is giving you trouble, please tell us what’s going on or give us the error message you’re getting, so we can try to sort this out …

1 Like

Thank you so much. I have just tried the manual install using a different laptop and it seems to have worked! It’s taken three days to try everything! I really appreciate your help and extra information, thank you!


The manual reinstall worked perfectly for me. Thanks so much. I was freaking out. :wink:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.