Stuck in Team Win Recovery Project after Android update

Hi all!

I’m new to the forum, but I’ve had my Fairphone 2 since August of last year. No major complaints really, but I’ve been scratching my head about this for the past few days: I can’t start up my phone properly. I’m not tech-savy at all and most of the relevant terminology goes lost on me, so I wanted to ask for help here in the forum. I hope I’m able to explain it well enough, English isn’t my native language.

So, a couple of days ago, I received a notification which told me an update was ready. The operating system of my phone would be updated from Android 2 point something (don’t remember the exact version), to Android 7. This already seemed like a big jump for me (aren’t there supposed to be updates in between 2 and 7?) but as I said, I know next to nothing about this kind of stuff. I had performed OS updates before though, so I inclined, waited for the update data to be downloaded, and after that, let the update install.

When I checked my phone again, however, I found myself looking at the Team Win Recovery Project screen. This worried me because I’ve been confronted with TWRP once before on my Fairphone , but the issue went away on its own after a while (after removing and putting back the battery and starting up the phone, again, I believe, but it’s been some time since then). Other than that, I have no idea what exactly TWRP is or which purpose it serves.

This time, however, I seem to be stuck, I’m afraid. Whatever I try (removing the battery and putting it back, performing the recommended data, cache and Dalvik wipe or rebooting the system or powering off through the menu of TWRP, restarting through holding down the both the power button and volume up button…), I seem to end up in either of two situations: the TWRP menu, unable to get past it and access my phone as I knew it, or just the familiar start-up screen (black background, and in white letters: “Fairphone”, “powered by Android”).
The latter (where I mostly end up after removing and putting back the battery in order to get the phone to actually turn off), does not however have the blue frame appearing behind “Fairphone” and does not load further, like it normally does when it’s starting up; it’s simply frozen in that state, and remains this way until the battery runs empty and the screen turns black OR if I restart the phone by holding down the power button and volume up button; in that case, I end up in the TWRP menu once again eventually.

Does anybody have an idea what I should do to get my phone to function normally again? I’d rather not lose files on my internal storage, I haven’t transferred all of my photo albums or music to my SD card, and I use quite a lot of apps (which I’m afraid I removed by using the TWRP ‘Wipe’ function…) too. Would be a shame if I lost them… Apologies for the long post and thanks for your time in advance!

1 Like

It seems quite some people experience this with the latest update, possible solutions so far:

Worth a try when in TWRP …

A little more detail in between …

Apart from TWRP a manual install has helped people …

Depending on what exactly you wiped, files will be gone, that’s what Wipe is there for.

Normally, once you are in TWRP’s main menu, you can just connect your phone via USB to your PC, and Internal Storage would be available so you could copy files over.

If you happen to have #fairphoneangels in your vicinity, they could perhaps help you getting this all resolved.

Else you can #contactsupport, who will probably suggest the manual install, but who knows.


All right, I’ll give those options a try, thank you!!

On another note, via Advanced -> Copy Log, I found the error message which reads “Unable to find partition for path '/system”, and via the Reboot options “No OS installed! Are you sure you wish to reboot?”, does this perhaps bring further clarity on what might’ve gone wrong?

This was reported here as a “normal” feature of the TWRP version bundled with Fairphone’s OSes. No cause for concern so far.

There were cases in which this was a false alarm by TWRP. You don’t lose anything by just trying to reboot nonetheless.


I am having trouble updating my FP2 from my current OS version 18.09.2.
I can’t update to any of the following updates.
The phne downloads, but freezes every time, when it reaches the “teamwin” page.
Anyone who can help get my phone updated?

I moved your post here, see above for suggestions.

Thanks for the info.
I have tried to manually install the Update on my FP2.
But the program keeps saying it can’t find the phone, no matter what I do or how many times I start over.
Is there anything else I can do or is a complete rebooting of the phone necessary?

Hi! I have the same problem than the person that wrote thefirst post: I finally decided today to install the last update for my Fairphone and when it rebooted I got stuck in TWRP. I tried to remove the battery, same thing. I followed those instructions (Install” in TWRP’s main menu, then navigate to /cache by tapping “(Up A Level)” and “cache”, and hope is still there to select.) and ended up again in TWRP.

I’m very worried because I’m leaving tomorrow for 7 weeks and won’t have access daily to a computer. And I need my phone to access my emails. Plus I have all my train and plane tickets on the phone. I hope I can get help soon!

How can I get out of TWRP??
Thanks a lot in advance for any advice!

Was the update file there in /cache and did you install it? Any error message?

Alternatively there would still be …

1 Like

Yes, the uppdate file was there in cache and I installed it. Now the phone is doing something, maybe it’ll work out. Now it’s stuck on the picture “Fairphone Change is in your hands” with the blue spots moving from left to right.
I’ll see if something change in the next half hour and get back to you.

Thanks a lot for your fast reply anyway!!

Well just to specify. I first tried to install the uppdate file that was under cache and I got stuck again directly in TWRP. Then I clicked on something else (can’t remember) and installed it again.

Ah! And now it worked. I’m back to my phone. Thank you so much! It’s stupid but I got very dependant on this little machine…
Have a great day.

1 Like

Hm. Did you perhaps clear the cache or something in between the attempts? Would be interesting to know what solved it.

Well unfortunately I don’t remember. I hope it never happens again but if it does I can write it down so I’ll know for the future and be able to share my knowledge with others, stuck in the void of TWRP!
I know I followed those instructions (Install” in TWRP’s main menu, then navigate to /cache by tapping “(Up A Level)” and “cache”, and hope is still there to select.). When I had selected this file, there were two boxes I could click and I clicked one of those. Unfortunately I don’t remember what they said. Something about rebooting the system. And then it worked and the phone rebooted and the update was installed.

I’m sorry I can’t help more. But hopefully this can guide a bit some others.

I have spent the last week struggling with the latest update and found this thread extremely helpful. I also had the problem of the computer not seeing the FP2 during the manual upgrade. However I tried various leads and eventually one worked (I’m guessing although the leads work as chargers not all are data cables?). Hurrah phone alive again.

I’m having a similar Issue. Some Months ago I tried updating the Phone and it failed, letting me get stuck in a TWRP screen where nothing loads nor anything changes until I take out the battery and set it back in, in which case the phone reboots normally.

Some days ago I wanted to wipe the phone using the normal android options tool, but it got me stuck at the same place. That screen looks like this:

I manually updated the Phone from FPOS 18.09.2 to FPOS 19.05.3, but I’d still need to wipe it and just can’t because of this.

Can anyone help?


1 Like

I have a Fairphone 2 that has been running fine for a year or more with Android, not sure what version. I got a notification that I should update to a newer Android (again, can’t remember the number) and said ok. I didn’t think to create a backup beforehand.

The update started ok but then it crashed and the phone went to the ‘Team Win Recovery Project’ thing (I didn’t know this was a thing before last week so please explain everything very slowly in your answers, I’m a total Fairphone novice). I tried rebooting (using the ‘reboot’ button in TWRP, the power button for 15 seconds, and taking the battery out) but it restarted into TWRP again. I think I tried a couple of the other things in TWRP but didn’t know what they really do (I can’t remember what I tried now because this was a few days ago).

I think I need to wipe the phone and reinstall the OS but I don’t know how to do that and I don’t want to lose everything on my phone. I’m not really worried about photos (they should all be backed up on Google) or music/videos (I didn’t have any), but I would be really sad to lose my WhatsApp chat history as it has some personally important stuff in there. I had turned of the Whatsapp automatic backup (yes, stupid of me, I know) so now I don’t know if I can recover it through the TWRP thing. My battery drained super quick in TWRP - even plugged into my computer it went flat in a couple of hours!

So my questions are:

  1. Why did my battery drain so fast and is there a way to get it to charge up long enough to fix anything?
  2. Can I get at my Whatsapp chat logs through TWRP to back them up somewhere? (FYI I use Linux on my laptop if that matters)
  3. Once I’ve done those (if I can) how do I reinstall the OS?

As I said I’m a total beginner at this so please explain everything very clearly without jargon. Thanks!

1 Like

Worth a try when in TWRP …

A little more detail in between …

If I do this will it wipe my whatsapp history? I would really like to back that up before trying anything else.

The procedure I quoted should just install the update file (if it is still there). TWRP should have done this automatically, but perhaps got somehow stuck.
Installing an update file shouldn’t affect user data, but you are right to be cautious.

I don’t use WhatsApp, so I don’t know where it stores its history.
When in TWRP, you can connect the phone to a PC via USB and have a look at Internal Storage and the SD card (if there is one and it is configured as external storage) and copy stuff over to the PC.

I have it connected to my (Ubuntu) laptop right now but it hasn’t popped up in the filesystem like it usually does.