Stuck in recovery mode


Have been having huge problems with the Kola Nut update, going round in circles, and have lost all my Google apps, which won’t reinstall…

Customer services suggested following the manual update instructions here:

I’ve worked through them but have got stuck. I’ve transferred the .zip file across to the download folder as it says, but now I’m in recovery mode and I’ve got to the bit where you need to select the .zip file it’s not there, and now I’m stuck in recovery mode.

Can anyone help? I just want my phone back to how it was!



To get out of recovery mode you can take out the battery. Then you can reboot and try moving the zip file to the downloads folder again. Maybe it just wasn’t moved correctly?

1 Like

Thank you for your reply, after panicking it was stuck in recovery mode I managed to switch it off and on again.

Then realised that the instructions tell you to save the .zip file into the internal memory, but then once you’re in recovery mode, they tell you to access it from the SD card.

I plugged the phone back into the computer and resaved the .zip file onto the SD card and went back into recovery mode, and that time managed to access it.

Finally the update has worked, and after 3 attempts Google apps is now reinstalled as well.

Phew! That was much harder than it should have been.