Stuck in "Do not disturb"/silent mode

Since i updated my phone and put it in silent mode (do not disturb) I can’t get out of it. Nothing happens when I tap the “Silent mode” in the quick menu, and nothing happens when I press volume down and tap the “stop now”. is there anyone who has the same problem?

For now I have had to change the settings for silent mode so I can hear every call and message, but that makes it even more complicated when I really want the phone to be silent.


I moved this to #fairphone2help until it is clear whether other people are also affected by this.

Hi, I had the same problem once. I also tried a lot (as reboots, clearing cache…) but finally came only out of that via the following workaround:
Settings->Sound & notification->Do not disturb->Automatic rules->Add rule
Added a temporary rule there so that this rule just enabled and then DISABLED “do not disturb” mode (via setting “end time” to very soon). This way “do not disturb” finally was disabled again for me.


Thank you! It worked super for me, all I had to do was to create a new rule, then everything worked again.


I had this same problem but the workaround sorted it. Has a bug been raised about this yet? it definitely needs sorting - I use do not disturb lots

1 Like

I haven’t found that topic in butracker. You may add it there although I don’t suppose it will be fixed fast, caused by its sporadic nature.

I have the same problem. It started a few days after the update after working fine initially. The workaround from @Volker worked it seems (thanks!), but would be nice to get this working properly.

For what it’s worth, I’ve been using Do Not Disturb in priority-only mode and set to go off automatically at the next (repeating every weekday) alarm.

1 Like

Just for the record of it, and for what it’s worth for anyone bugfixing it: It also happened to my phone, and I “solved” it by making a rule.

I am also having this issue, and haven’t found a rule that properly resolves it as a recurring issue. I’m hoping an upgrade will patch this up

1 Like

Same started for me yesterday. Maybe it was related to adding a contact with a ‘No ringtone’ setting.
I could not get out of it - the workaround with the short rule was not working for me.
Luckily after pressing the ‘Volume down’ button and immediately disabling silent mode, then raising the volume with the slider, I’m out of this mode.
I will watch if this is recurring…


Should this be added to the bugtracker and does anyone know how to do that?

Just create an account in the #bugtracker and (after first searching if it has already been reported) create an issue report there.
Please come back and post a link the report here then.


I ran into the same issue today, I have not modified the OS and I am on the official Fairphone OS. I reported the issue to the bug tracker:


Thanks for adding it to bugtracker! I think that’s really good!
I just wouldn’t see severity as “major” (but more as “minor”) as it’s easy to solve when you know how to and as it seems to happen very rarely (at least for me only once and according to this thread for others also rarely).


Update: Developers at Fairphone “rejected” the issue, there will not be a fix by Fairphone as long as the Fairphone is running android 6. The reason for the rejection is, that this would be a “generic” and rare Bug directly in the Android codebase that affects other devices but never got fixed by Google. Rick from Fairphone supplied thus link:

Please use the workaround above, which worked for me.


Well I have just updated to the latest software and now have this bug too. Quite irritating.
I also suffer from the “do not disturb until next alarm” not available at the end of the month bug (!)


I’ve been using the “do not disturb” mode almost every night for more than a year.
I’m using Fairphone Open, and the problem appeared for the first time with 17.09.3 and is still a problem in 17.10.1

mav’s workaround works for me:

1 Like

I tried that suggestion. Didn’t help. Why is this post closed?

1 Like

Have you tried @mav 's suggestion or my workaround from post 3?


I experienced this bug too: simply adding rule and modifying the time of this new rule (as suggested above) was not sufficient enough. Luckily re-doing this (create a rule and modifying time) in #dic:safemode helped to remove this stuck notification.