Stuck at the step "unzip <zip>" in /e/ OS installing on my fp3

Hey, today i’ve finally been trying to install this eOS on my FP3 :slight_smile:
I kindly followed the official tutorial: https://doc.e.foundation/devices/FP3/install
So I:
:white_check_mark: unlocked the bootloader
:white_check_mark: restarted my phone in fastboot mode
:white_check_mark: downloaded the /e/ image ROM

Problem: reaching the step “Installing /e/ from the bootloader”, i realize that i dont know where the image had to be downloaded: i tried to put it on my laptop, in the “platform tool” file for example
Or; on my phone itself, in the internal stockage
–> i tried them both zipped and unzipped, because using the cmd i was getting this message:
“unzip” is not recognized as a known internal command.

  • Commands as “fastboot flash system system.img” couldnt find the file
    While “fastboot -w” was working

I hope somebody will come and give me a hand, i would be really grateful :heart_eyes:

1 Like

see if you can use the GUI to “extract” the contents to the folder, then move the directory in terminal to the new folder. You might be able to use “open in terminal” in the folder to help, then fastboot stuff should be working.

I hope that makes sense

2 Likes

Okey, i found the way to do it :slight_smile: Maybe its not the right one but anyways im now a eOs user! :slight_smile:
This is what i did:

  • Unzip the file from my computer in a folder (on the computer, e.g. using winrar or the default windows method)
  • Open the folder
  • Shift + click in the file: open powershell window
    Continue the instructions of the official tutorial :slight_smile:
    (Wich are:)
  1. Install /e/ using the following commands (from fastboot mode)
 fastboot -w
 fastboot flash system system.img
 fastboot flash boot boot.img
 fastboot flash vendor vendor.img
 fastboot flash dtbo dtbo.img
 fastboot flash product product.img
 fastboot flash vbmeta vbmeta.img

 fastboot flashing lock

The last command will ask you to confirm on the device to lock the bootloader. Select LOCK THE BOOTLOADER with Volume + and valid with Power .

On previous version of fastboot , the last command is fastboot oem lock

  1. Enjoy! The device reboot automatically on /e/.

And boom ! You made it :slight_smile:
As a super newbie to adb/fastboot, i think it would be easier for people like me to integrate this part of tutorial in the real one, it would create less bricks and make more power users in the community :slight_smile:
@rhunault :slight_smile:
Thanks @athair_birb !

5 Likes

Hallo @Justanidea,
I had the same problem a few weeks ago. I am also no expert in writing commands and where therefor confused where to save the zip file. Then I remembered (and saw at Windows Power Shell) that Windows Power Shell access “C:\Users\ *Username”. So in order to work I had to put the zip file in this folder (C:\Users\ *Username). After that everything worked just fine. I hope this helps someone in the future.
I am pretty sure there might be another sulution with a command that select a disired file form another source (other than C:\Users\ *Username), but I don’t know the right command. Out of curiosity is there someone who knows it for PowerShell on Windows and would like to share?

I fully agree with @Justanidea, that an integration of this part on the tutorial would be greate for noobies like us.

Kind regards

P.S: Please don’t hesitate to correct me if my sulution contains mistakes, it is possible that I forgot something or mixed something up. After all, this isn’t my field of expertise. :slight_smile:
P.P.S.: (Sorry for my english, I am no native speaker. :wink: )

Well I’m certainly not an expert, but I would say cd "path" just before executing the other commands. For the desktop for example cd C:\Users\"Username"\Desktop (I’m not sure, I run Linux)

2 Likes

Just ask an older “DOS/Windows guy”. :wink:

An install guide for Lineage OS on a FP2 recommends to add the path of the ADB utility to the Windows PATH environment variable value. This way, someone can call the ADB utility from any place, regardless which directory has been entered in a DOS shell emulation before. (The same should be valid for Powershell.)

1 Like

Yeah :grin:

But I’m afraid I didn’t understand your explanation at all :sweat_smile: Could you develop a bit more for us, poor non-techies?

1 Like

I doubt that. :wink:

Here is a description of the PATH environment variable in Windows: https://en.wikipedia.org/wiki/PATH_(variable)#DOS,_OS/2,_and_Windows

Basically it is a list of paths Windows visits one by one to find an executable program when it is called/run from the DOS shell.

2 Likes

Thank you @Alex.A and @DeepSea for your solutions!
I tried your solution alex and it worked just fine. I tried for example: “cd D:\Downloads\ " and the path Windows Powershell used in the next line was as wished D:\Downloads\ and not like before C:\Users"Username”. So thank you very much!
I am also thankful for your suggestion DeepSea but I must confess you lost me somewhere in the middle :smiley: . I tried to understand the wiki article but I am not sure if I got everything right. After reading there: “If used unwisely, however, the value of the PATH variable can slow down the operating system by searching too many locations” I was insecure if a non-tec like me sould really choose this solution for an one time problem. :slight_smile: But don’t get me wrong it is very interesting for me to read that something like that is possible and I am thankful that you gave me that hint.
Kind regards

3 Likes

Great, many thanks for reporting back!

In fact, this wiki seems to be too general, as the PATH environment variable is widely used on each Windows system anyway. The warning might be valid for a 30 year old PC running DOS. Therefore, nobody must fear a slowdown after adding further paths to the PATH variable.

1 Like

Thank you @DeepSea for this clarification! Next time I need it, I will try out adding further paths to the PATH variable. :slight_smile:

1 Like

The environmental variable that is “PATH” exists solely to ensure that programmatic automation operates correctly/identically despite different placement of binary software during utilisation of different operating-systems. “cd” or “Set-Location” is what should be utilised to remediate what “Stuck at the step "unzip <zip>" in /e/ OS installing on my fp3” describes.