Stuck after Android 6 Update... going back to 5.1 as well!

Hi all,

Yesterday I did an update to Android 6 with the updater. Everything seemed to go well, but then after the update when my phone would get stuck at the boot screen (Fairphone, blue dots moving from left to right). I left it there for around 20 minutes but no luck. I tried my luck flashing with fastboot, but this does not help either.
I had to flash recovery, since I could not get into recovery else (I’m aware of the changes in Android 6 regarding access to recovery).

Before I was using an unrooted version, one or two releases before 1.3.1.

Today I tried flashing 1.3.1 in recovery. I had problems starting the phone as well, that’s why I tried:

  • wipe cache&dalvik
  • install gapps from recovery
  • install xposed framework from recovery / uninstall xposed framework from recovery

At first I would get into a loop of booting and app optimization.
Then I also got it into a state, where the phone would boot and show the lock screen for a couple of seconds and then boot again. The bars on top/bottom show up and disappear. This is the state in which my phone is currently in.

I would love to have Android 6 running, but my highest priority is to have my phone working again. Could you give me some recommendations on what to try? I would prefer not to factory reset!

1 Like

Well I had some troubles getting 6 working aswell, because of root and xposed so I went back to 5.1. You can try to download the OTA from 5.1 and apply it from recovery or via adb sideload. First you might want to flash the recovery again with fastboot. I think you can find tutorials about it here in the forum. I hope the downgrade will be smooth for you, because it fucked up for me (thank god I had a backup of the data, but still… it took several hours).

I tried to go back to 5.1 (FP2 version 1.3.1), but it crashes as soon as I reach the lock screen.

I did a factory reset after I tried everything I could think of… flashing Android 6 gave me:

C:\fp2rom>fastboot flash system system.img target reported max download size of 536870912 bytes erasing 'system'... OKAY [ 0.054s] sending sparse 'system' 1/3 (519787 KB)... OKAY [ 17.005s] writing 'system' 1/3... OKAY [ 12.097s] sending sparse 'system' 2/3 (524183 KB)... OKAY [ 17.258s] writing 'system' 2/3... OKAY [ 17.825s] sending sparse 'system' 3/3 (184 KB)... OKAY [ 0.012s] writing 'system' 3/3... OKAY [ 0.032s] finished. total time: 64.289s

Now I’m stuck again on the boot screen. :rage:

I installed 5.1 again from recovery and then did the update to 6… the updater gave me an error in recovery (something like unexpected content). Flashing didn’t work either. Now I’m back to 5.1 again after a factory reset. :cry:

Weird… I think I had the same issue with updating to Android 6 and also had to re-flash 5.1 before I could run the MM update successfully. The only thing I probably did different was that I flashed version 1.13.0 using the updater. For more details see my post here.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.