Strange FP2 Mainboard Defect: Do you have a clue? Can you repair it?

Dear Community,

My FP2 stopped charging. At first it wasn’t accepting charge from the plug socket. I charged it via USB from my Laptop. Some days later it didn’t charge at all. I bought a new Bottom Module and a new battery. (this was several months ago) This didn’t help either. In the meantime I was charging the two batteries with an external device to keep it working somehow. I’ve got a used motherboard from a donation. And voila, it works again, which makes me very happy :grinning_face_with_smiling_eyes: and grateful for the donation :pray:

Now to the really weird part: I connected the FP2 to my laptop. And see there: fastboot can actually transfer an image to the phone and flash a new OS image or Recovery System. That way I was able to reset my phone via TWRP and manually installing the FP2 OS. Unfortunately the problem wasn’t solved. fastboot still worked fine as before, but adb, charging, and data transfer wasn’t possible. Changing the USB-Mode in Developer Settings wasn’t possible. The change was only visible after the settings app was closed and reopened again.

Do you have any clue why fastboot works, but adb does not? Why can it transport data via fastboot but not charge? Why can’t adb transfer data while fastboot can?

adb works when the system is up. At this time, fastboot can’t do this job any more.

hmm… ok. Booting into TWRP and trying to sideload an image via adb wasn’t possible though.

The defect looks like a software error to me. I am a Web Developer and I am probably biased because of it xD It’s just so strange that fastboot works and the other tools don’t.

Any ideas on how we could try to fix this?

Fastboot only works in fastboot mode (also called bootloader). ADB works only in the system and in recovery mode. But when one works, that means the other won’t.
If ADB doesn’t work when it should, then that’s another problem.

Where and when is it not charging? In fastboot mode? While booted in the system?
My bet: when plugged to a computer, you might only get 0.5A of charging current, which is barely enough to charge the phone when in use, and sometimes not sufficient if something battery-draining is running. Does it charge better when plugged in the wall?

Hmm, well, you might have a too old version of fastboot and adb installed on your computer. I already experienced a similar case, adb would work but not fastboot. Perhaps you could try the last up-to-date version of the platform-tools.
What OS are you running on your phone and your computer?

Normally the system is EITHER in fastboot mode OR in adb mode. But I believe you’re right: adb sideload in recovery should work out. But if in that particular state fastboot is working then it won’t work with adb.

Where and when is it not charging?

It didn’t charge in any mode. I tried different cables, adapters and sockets: wall mounted sockets and USB to laptop. I also checked if the cables, adapters and sockets were able to charge other devices. They were.

What OS are you running on your phone and your computer?

I was runing FP2 Open OS. Later I reinstalled FP OS (with google apps) to try if it fixed the problem to no avail. Installing /e/ or lineage didn’t work, because adb sideload with TWRP wasn’t working.

My laptop runs Ubuntu.

The Current State

A used FP2 motherboard was donated. With the new motherboard all parts work again. Charging and data transfer are working. I installed /e/ and after that I installed lineage OS. Currently lineage is my choice and it works pretty well after I fiddled with the dev settings a tiny bit. There was this one button to disable some hardware rendering feature. If you are interested I will look up the name of the setting.

You could flash from a SD card via TWRP

To make things clear: this thread is mainly for curiosity. And secondly it is my last effort to save the old motherboard which was originally part of my FP2.

Ok, thanks for mentioning. I had misunderstood and thought you were having problems with your new motherboard as well.

What happens if you press very hard on the spot where the connectors are? Perhaps the pogo pins on the motherboard connecting to the bottom module are somehow broken. You could try the oven method:

Though :warning: I have absolutely no idea whether this will or can help, and out of experience I can tell you it may also completely kill the motherboard.
Perhaps by heating the pins in an alternative way you could get the same result.

1 Like

thankyou for the idea =D

I’ll try something like that. As soon as I have some time I’ll go to our CCC-Club in Trier. Maybe there I will find some people with more knowledge and hands on advice.

The motherboard I currently use has some issues too though. I get screen freezes from time to time and pixel artifacts alike described in the post you mentioned. First I will try to clean the pins and contacts.

1 Like

Sorry to hear that the core module I sent you is not working well, I had the impression from a more or less short test it would. the issues with freezing from time to time and when using the browser that parts of the screen show some “black and white snow” for a few seconds I see at my daily driver as well, also reboots sometimes more sometimes less…at the end it does not annoy me too much so far and I take it as training for my patience😉
If the core module is too bad let me know I might get another one the next days.

1 Like

Hi ^^

it is ok so far =D I cleaned it in hope to solve the problem. So far it did not freeze anymore. Sometimes it prints “snow flakes” on to the screen. It is acceptable in my point of view.

Thankyou very much :pray:


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.