Stock fp3(+) (factory reset) boot loop (workarounds in first post)

The miracle of the weekend :smiley:

1 Like

@Pilo11 YOU ARE A HERO!!!

Your adb tutorial helped me recover my FP3!

I had Developer Tools activated already, but not USB Debugging. But this was possible for within the 10-seconds-timespan.
After that I was able to reach out to the phone via USB and could install the earlier Google Play Services app. Excellent!!!
FP3 running now. I’ll back up everything now and then I’ll go for Lineage, I guess…

Edit: I disabled automatic updates (like @amoun suggested) in Google Play Store > Settings > Network Preferences > Auto-update apps > Disable.


I really don’t know. The Google Play service cannot be solely responsible for this, otherwise many other smartphones from other manufacturers would also be affected. But it definitely has something to do with the update and version 22.44.16. I have a second Fairphone that still has version 22.43.xx installed, I installed 22.44.16 there and exactly the same problems occurred after a reboot.


@Pilo11 Thank you very much!
Your guide allowed me to downgrade Google Play Services and (so far) the phone seems to be stable again!


Isn’t there any way to switch off the whole possibility to reboot by itself altogether? It has no purpose (rebooting has of course, but just manually) and it makes finding solutions so painstaking!

1 Like

Framwork has to submit updates to Google. Google do over 2 million security checks and if they are sure it’s OK then Fairphone can release it.

Between Fairphone submissions to Google, google do updates without Fairphone approval so yes it is down to Google, though it may be because they missed an underlying issue in the Faiphone OS from a long time ago.


FP have confirmed that they’re working on this / treating it as a priority.
Beyond that, there won’t be much value to them commenting on this post (PR aside, perhaps) until they uncover the cause and have a fix. These issues can be complex to figure out; especially when the issue’s not reproducable (i.e. not all fairphones seem to be impacted at the same time; so it’s possible that they’ve not got a faulty phone to see the issue first hand on / try stuff out on… unless our theory on Google Play Services is correct and they’ve therefore been able to reproduce the conditions required for the issue to occur). If the issue’s caused by components from a third party it’s also harder for them to fix, as they can’t correct those components; so they then either need to set their code to pin the component to a version prior to the issue, or to work out a way around the issue from the outside.
I don’t know if their teams work weekends; but its likely that at least most staff (including any who’d cover comms) won’t, so I wouldn’t expect updates until Monday at the earliest… likely later if they haven’t uncovered anything worth communicating.


Downgrading Google Mobile Services according to your tutorial has also worked for me. Thank you so much @Pilo11


Thanks Pilo11: I followed your instructions and now I’ve my phone working again :slight_smile:

1 Like

Hmmm… My initial joy at my phone not restarting anymore has been replaced with puzzlement as I seem to have lost any and all form of internet connectivity (wifi and 4G)… Although both are enabled, my phone can’t seem to make a connection. Don’t know if it’s related, but internet worked fine before the downgrade… Maybe something wrong with the version vs my phone? Not sure… But apparently not a clean fix for me after all. Not sure what I can try next. Maybe installing a different version? Any help is much appreciated!

EDIT: Resolved. I noticed the time and date on my phone were completely wrong (I was somewhere in September). Apparently the “use network-provided time” setting had previously been disabled. After re-enabling it, all connectivity instantly came back. Not sure how or why, but if your clock is not set correctly you don’t get internet :slight_smile:
Anyhow. Apologies for any confusion and thanks again @Pilo11!

1 Like

same problem here, also reported it just so they know. will try @Pilo11 s method and update in an edit to this post. thx

1st edit: ok lol I’m stuck at the first step, how do I activate developer tools and usb debugging? I’m sick in bed rn and have trouble reading things and finding that information right now, can somebody run me through this. thx alot. (do I still need to do a factory reset and lose data when following this option?) tysm

Hi everyone, I’m new in the forum
The same issue appeared on my FP3 today (Nov 12, around 12.30 CET): it is stuck in a reboot loop (only a few secs after unlocking the screen)

  • I purchased my FP3 back in 2019
  • My provider is Orange (France)
  • I hold a single SIM (no 2nd user account)
  • I’ve tried a couple of restart configurations (Safe Mode, with and without SIM card…) but nothing helped
    I haven’t tried resetting the factory configuration because I have a lot of pics & videos with NO backup yet :scream: !!
    And I’ve read about some alternative solutions in this thread that I don’t want to try either, until I get my data safe on some external drive (Note: I’m no expert, so some solutions such as in developer mode may be risky)
    At present time, my main and big problem is: does anyone know how to safely retrieve my data from the phone memory (particularly photos and videos) knowing that I cannot connect my FP3 to my Google account nor to my computer (via USB), since it constantly reboots ?
    ThanX for any suggestions!

Settings > About phone > Build number ~ tap on it 10 times to activate.

Then next time, if it switches off

Settings > System > Advanced > Developer options > USB debugging

Tutorial to activate USB debugging:

Then you need to install adb on your computer (MacOS/Windows/Linux). And type those commands into your Terminal. There are plenty tutorials on youtube out there. NO you DON’T need to reset your phone and lose data. That’s the reason why I posted this way. For me a factory reset Is not an option.


With my USB debugging ADB way you are also able to copy your files from your phone to your computer without unlocking it. You only need to follow the USB debugging activation steps. It’s not very convenient to copy files with the ADB shell but it’s possible without risking data. In addition you can do the downgrade without any risk. It’s just an application installation progress. No crazy hacking/manipulations. It only looks a bit strange due to the terminal commands. GUI looks more friendly.


Same problem Friday 10 nov

1 Like

tysm for taking the time. this is super helpful! have a great day

This just got me my phone back! Thank you so much!

1 Like

Thanks so much - I have been experiencing the same issue since last night (early hours 12/11) on a FP3 and this worked. Involved connected through ADB, clicking notification to always trust the connected computer, and then on the next reboot ran the commands before unlocking the phone. Have now disabled Google Play updates and seems to be running fine for the time being.

1 Like

@Pilo11 how have you been able to copy files before unlocking? I fiddled around with ADB / shell commands for hours and I only received messages that either the path was not found, or I did not have the rights to access those disks / data…