Still two storages after unified storage partition

Hi,
at the risk of having missed the solution that already deals with my problem:

My FP1 told me that there is insufficient storage for installing app updates. So I have tried to install the storage upgrade several times (WiFi activated) but after rebooting I can still see one internal storage and one telephone storage. I also have an SD card that is virtually empty.

What can I do?

Regards,
Jule

Try again with the phone plugged in and the “stay awake” option ticked (in developer settings).

Thanks. I did it but the storage is still parted.:no_mouth:

Well the I guess you should try updating manually.

1 Like

Thanks again. I updated manually and everything seemed fine (no error message or the like) but there are still two storages. :confused:

Does your Fairphone run Fairphone OS or Stock Android?

Android 4.2.2

Well, you might have to install Fairphone OS first if you haven’t got it installed yet. I guess Fairphone’s storage update might not work with stock Android. @paulakreuzer ?

Also be prepared that you might have to install (Fairphone OS) manually, i.e. from your SD card in recovery mode.

1 Like

Okay, the Fairphone Updater says that my current version is Fairphone Kola Nut 1.8.7. So I must have Fairphone OS, right? If yes, there must be another problem. Supposedly, my storage is running out and some functions are not working correctly anymore …

Since you didn’t know you had Fairphone OS 1.8.7 installed I have to ask: Did you use the right storage upgrader?

Sorry for the confusion, yes, this was exactly the link I used. I tried several times …

Sorry if this bugs you, but just to avoid any misunderstanding: When you say you tried updating manually, you went through recovery mode and applied the storage upgrade file (while being in recovery mode) that was saved on your SD card?

I sourced this from another thread:

@Barth means the “wipe cache partition” option in recovery mode.

2 Likes

No problem. Yes, that‘s what I did. I followed every step of the tutorial.

1 Like

Thanks Stefan, I also found this thread about clearing the cache before rebooting, but this also did‘t work. Hmpf! :unamused:

Since the Unified Storage Upgrader deletes all files on your phone anyways, you might as well try wiping data before applying the Upgrader. Does this help?

Thx, I‘ll try this in the next days and tell you if it worked. :santa:

I tried everything that is adviced to get get one partition for koala nut, but still have two partitions so cannot install the required update for Whatsapp because there is not enough space in internal storage (there is 101 MB free, I thought this should be enough). Is it advisable to go back to factory settings ?

The Unified Storage Upgraded wipes all your data anyways, so yes, you could try a factory reset.

PS: It is Kola Nut, not Koala Nut. :wink:

1 Like

Stefan thank you for your help. Kola or Koala my FP1 seems ‘nuts’ :smirk:: even factory reset doesn’t work. Possibly the reason why the unified storageprogram also doesn’t work. Hope for a solution and can be happy again with my FP

1 Like