Someone with a FP3 in Scotland? [Water damage]

Hi and welcome to the forum

That is odd

  • I’ve never seen a blinking red light by the camera, do you mean to the left of the ear speaker, the camera is to the left of the ear speaker

  • The phone will not work without the battery. The power goes via the bottom module USB C port to the power chips on the core module. The core module communicates with the battery to see what charge is viable.

You may still have damp issues and maybe some contacts are tarnished and hence there is no signal to charge or power on.

The battery maybe completely discharged and if so you will have to leave it plugged in for some hours for it to gradually accept any charge.


  • Check the b battery voltage. If it’s 3.8V that around 40% charge and should power onand if not then it’s not a charging or battery issue

  • If the voltage is 3,5V or lower then you will have to try and charge it slowly or alternatively externally to the phone.

  • Check the battery isn’t distorted ~ battery spin test

  • See this post for links and ideas

Removing the bottom module requires removing the display module where you have access to it’s contacts and can check for
[red square]
[red solder] etc.

The two links above are just odd posts from FP3 charging topics

1 Like

Thanks, I didn’t know about the Fairphone Angels!

1 Like

Thanks for the many interesting links! I didn’t know about the earthing contacts, and it might be the cause of my problem cause they are quite dirty.

I’m attaching here a picture of the phone right after I dismantled it and before I cleaned anything (careful, it’s nasty). As you can see, there are white traces almost everywhere (but curiously the dampness square did not turn red)… I managed to get some off first scraping with a plastic tool and then with a cotton swab and ethanol, but it’s nowhere near perfectly clean, especially around the mentioned earthing contacts (both for the squares at the back of the screen and their counterparts on the metal plate).

What would you recommend to clean these white traces more thoroughly? In a topic that you linked isopropyl alcohol was mentioned, is it any more efficient than ethanol or are they similar?

1 Like

They are very similar in the ability to adhere to oil deposits.

  • Iso is usually cheaper than Ethanol
  • Ethanol is less toxic if you have children around.

So is the ethanol >90% ?

You may want to try using a tooth brush to ‘scrub’

Also you can dilute 90 down to 70 and the water may help with salt residue.

Quite odd and telling that the little square is still white,

Check the pogo pins move.

1 Like

Sorry I didn’t answer your question about the blinking LED: I was talking about this one.

I’ll see if I can get my hands on a multimeter to test the battery’s voltage.


Yes that’s the only one I was aware of :slight_smile:

So is the ethanol >90% ?
You may want to try using a tooth brush to ‘scrub’
Also you can dilute 90 down to 70 and the water may help with salt residue.

The ethanol I used was actually already diluted to 70%, but I’ll try again with a toothbrush!

Check the pogo pins move.

I tested every pin individually and they are all able to go down and up again


First use a toothbrush to gently remove the debris. In a second stage use a copper brush gently.


I’m not a Fairphone Angel, but I am in Edinburgh and own a FP3 although I already made contact via Reddit… I hope the cleanup attempts go well, but otherwise I should be on hand to help test it when you’re here in August. Probably best to use Reddit to message me then since it actively notifies me!


So yesterday evening I cleaned the inside of the phone more thoroughly with 70% ethanol, let it to dry for a day, and assembled again just now. When I plug it in a socket I get the Fairphone welcome screen and a vibration for half a second, then the screen goes dark, and this repats on and on.

Based on what you said @anon9989719, I would guess this is because the battery is completely discharged and cannot give enough power for a full startup. So I’ll try to leave it plugged for some time, hopping that the half second of startup I get in repeat does not draw more power than what it receives at the same time!

I tried to unplug it and press the power button, and nothing happened. When I plugged it back in, this time the startup went up to the “bootloader is unlocked screen” (it runs LOS), then another Fairphone screen, then back to the infinite loop.

Based on this post I guess it might be due to the battery being dead, so if letting it charge doesn’t work I’ll try and get a new battery!

1 Like

I noticed that if I pressed the “volume up” and “volume down” buttons simultaneously while the phone is plugged this would break the infinite startup loop and turn off the screen. So I did this and left the phone plugged during the night, and this morning I tried to turn it on and I got the infinite startup loop again.

Then I guess the most logical thing to try is to get a new battery? (as I said earlier, I won’t get the blinking “charging” LED when the phone is plugged and the battery in, but I will get it once the battery is out)

That doesn’t seem to be a battery issue as with no battery there should be no LED

As the charging circuit, which controls the LED is on the core module I tend towards thinking the core module has a short.

If you are out of warranty you could try a more in-depth clean

I cleaned it again twice, almost soaking the modules and the inside of the phone with 70% ethanol, then brushing with a toothbrush to remove the white residues, and letting it dry for 2 days each time.
The problem is still (almost) the same: it won’t get past the boot screen, and the charging LED is still blinking when the phone is plugged without battery in even though it is not supposed to. The only things that changed are that:

  • Instead of an infinite loop of boot screen for half a second, every now and then it does a “longer boot” (but it never goes past the second Fairphone welcome screen, see video here)
  • Now, when it is plugged with battery in and it is in a infinite boot loop, if I plug it off it will continue the boot loop (whereas before I think it would just turn off)
1 Like

Update: I left the phone charging for a few hours, and when I came back I had the charging screen that you normally get when the phone is off and plugged (a lightning bolt inside of a circle that represents the charge percentage), but when I pressed the power key I got the same behaviour as previously.

1 Like

Another update with some good news: the phone is finally able to boot! Here’s what is working correctly:

  • Display and touchscreen
  • Speaker
  • Microphone
  • WiFi

Here are the problems I encounter:

  • The battery level is always 50%, and even when the phone is plugged it reads “Connected, not charging”. The phone sometimes turns off when I unplug it so for now I am using it connected to a power bank. I tried to dial *#*#66#*#* as mentioned here but this didn’t show any menu. As my phone is under LOS is also tried to dial *#*#197328640#*#* (found on this Reddit post) but this didn’t work either. The *#*#4636#*#* (from this other Reddit post) did make a menu appear, but it only has Phone information (mainly network settings), Usage statistics and Wifi Information menus, so nothing to check the battery health.

  • I cannot send/receive SMS and phone calls. On the lock screen the top bar shows “No SIM card” (although during booting it asks me for my SIM PIN and shows the correct network provider). When I try to make a call I get a “Turn off aeroplane mode” message and under the name of the contact I selected is written “Radio off”. When I go to Settings > Network and Internet, under Calls and SMS it is written " (Temporarily unavailable).
    However, this might be due to my SIM rather to the phone: I had my SIM cut from standard to nano size in a shop, and when I put it in the first time it didn’t work right away, I had needed to take it off and in several times before it worked (my SIM is old and I think I read that the newer ones, which you can directly cut into nano yourself, are thinner). I will try to order a new one.
    Interestingly, when in the *#*#4636#*#* menu, I am able to see the contacts saved onto the SIM so the phone is clearly able to detect and read it!

1 Like

Two things

  • Some SIM cards, when they are cut are not quite right. Even a small width discrepancy can cause the SIM to bend and not make good contact
  • The card may also be slightly thicker and bends and . . .
  • The contacts in the SIM may be tarnished, so if you can get an old SIM and push it in and out a few times it may help clean the contacts.

Info on thickness to follow, but best get a new SIM to be on the safe side.

I’m impressed with your perseverance.

Well the purpose of buying a Fairphone was to keep it as long as possible, so I wasn’t going to throw it away before having tried everything!

I received my new battery today, but the phone still behaves in the same way (i.e. battery level shown is always 50% and phone won’t work without being plugged). May this be due to one of the modules being faulty, or does this look more like a core module problem?

Sadly the core module is the only one that manages charging etc.

The phone will work without the ‘other’ modules, so you should be able to remove the bottom module with no change.

The bottom module only feed power to the core module which then decides on how best to charge the battery, the phone will not run from the mains, i.e. without a battery