[solved] Restoring TWRP Backup fails (Error 255)

I just had a problem very similar to this one. I tried to create and restore a Backup with TWRP 3.4.0, but restoring always failed at 94% with this message:

extractTarFork() process ended with ERROR: 255

And in the logfile I found this:

tar_extract_file(): failed to extract //data/app/[...]/base.apk !!!
I:Unable to extract tar archive '/external_sd/TWRP/BACKUPS/[...]/data.ext4.win005'
Error during restore process.
I:Error extracting '/external_sd/TWRP/BACKUPS/[...]/data.ext4.win005' in thread ID 0
I:Error extracting split archive.
Error during restore process.
extractTarFork() process ended with ERROR: 255

As I did not find a solution online, but many others facing similar problems, I just want to share how I solved this.

  1. Save TWRP Backup to external SD
  2. Backup (e. g. via MTP) internal storage (i. e. /data/media/0)
  3. TRWP -> Wipe -> Advanced Wipe -> Check everything except Micro SD card
  4. Restore TWRP Backup
  5. Restore internal storage (e. g. via MTP)

I’m not sure why wiping the internal storage solved the problem, but I guess that the restore procedure somehow ran out of storage. I hope this will help others facing this problem.


2 posts were split to a new topic: Restoring TWRP Backup fails (Error 255) on a Xiaomi Mi9T

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.