[Solved] Phone sensors stopped working after installing experimental image [Ubuntu]

Hello,

The short version first: I have a very strange issue where screen rotation, proximity sensors, accelerometer data (tested in satStat, hereby just called the “sensors”) does not work neither in plain FPOS, flashed from the latest offline installer, nor for DivestOS (which is the only other Android variant I tried). However, for some reason it DOES work on the experimental new Ubuntu Touch build, by using the UBPorts Installer! Other things like wifi, LTE, GPS and BLE works completely fine in all OSes.

The longer version, on what I’ve done since I got my FP4 last thursday:

After my first startup of the OS I immediately went through the steps of unlocking OEM and the bootloader. Sadly, I can’t remember if any sensors were working back then, I probably didn’t test to rotate the screen.

My first go at an alternative OS was the fresh version of Ubuntu Touch from UBPorts, which worked mostly fine for a few days, sensors included (screen rot + turn black during calls). I also at some point tried to build my own modified kernel with Wireguard included, which worked as far as booting, loading the kernel module and connecting to my server. Except once connected, no other apps seemed to be able to use the connection. This is beside the point, but I just wanted to include “modified kernel” as one of the OSes I tested where sensors also worked.

Not being able to use Wireguard was a no-go, so I decided to jump over to DivestOS for now. This worked fine for almost a day I think before I realized I wasn’t able to rotate the screen by turning the phone, nor did it turn off the screen during calls. So to be fair, I don’t know if this stopped working right then or at some earlier point.

After a lot of troubleshooting, as well as attempts to flash only parts of the FPOS offline installer (Divest devs suspected a driver/firmware issue), I finally gave in and decided to download and flash the full FPOS package, wiping everything in the process. But again no luck, not even after upgrading from the settings updater, multiple reboots and turning the developer option for sensors off and on. At this point I was afraid I had broken something in hardware during one of the flashing operations.

So I decided to go back to where I know at least screen rotation worked in Ubuntu Touch, and to my pleasant surprise, it still WORKS there! I also downloaded an app from the store to read out sensor data like SatStat, and everything seems to be putting out rotation/gyro/accel data as expected.

Still, not having Wireguard was worse for me than missing screen rotation, so I decided to give DivestOS another go. Sadly I still can’t get sensors working there. SatStat shows only dashes (-) on the sensor readout screen, and screen rotation won’t work.

Not sure where to go from here, so I’m trying my luck in these forums before maybe contacting support. Since the sensors themselves seem to be functioning (in Ubuntu) I guess it can’t be hardware related, but I don’t know if there’s ane more things I can flash to get things back in a working order on the Android side.

Oh and lastly, late last night on a whim, I tried to unscrew some of the components inside the phone and put them back again (this was before the second Ubuntu test), but that didn’t help either. And on multiple points through troubleshooting I tried to turn the phone off, remove the battery, wait a few minutes and put it back in.

I am also suffering from the exact same issue after flashing Ubuntu Touch. I’m worried that by doing so some of the data in the persist partition is now corrupt… Sadly I do not have a backup of persist so I can also not test this, but the fact that the sensors still work in UB, but no longer on stock android seems to indicate that persist might be corrupted.

Anyone perhaps has any clues as what I might try to recover this without having a backup persist.img or is my best bet to contact support?

Also for anyone wanting to flash Ubuntu Touch be warned!

1 Like

Are the sensors also not working when testing with the app below?

Will test using that app, but did try another app to test sensors and that one failed

There is by the way also an internal troubleshooting app. It comes with the phone. It allows you to test your sensors as well.

However only available with Stock ROM not with custom ROMs?

True, but I would personally also say that it’s better to contact the Ubuntu Touch community if there are issues with that. If we get all the issues here that people have with GCam and 3rd party ROMs then the reputation of FP is not getting better when people scroll through the topic titles. But I don’t decide that of course :nerd_face:

I would not agree to that as you cant always nail down (as described in the first post) what is causing the issue. When its clear its most likely an Ubuntu issue, sure this will only be fixed when reporting in their forum. Still reports here might prevent others will run into the same issue. Its not “black and white” and you cant exclude everything not 100% a FP issue (an issue that can solely be fixed by FP). And as you mention Gcam: I have not seen any issue reported here which is a Gcam issue. Furthermore there were times not too far away when you asked to not Sugar coat things. When you stop topics like this, to me this would actually be sugar coating. Custom ROM and Apps (good as well as bad parts of it) are part of the Fairphone and part of this Forum.

2 Likes

Thank you all for your respose, I am so relieved I’m not the only one having this issue. I also want to say that I don’t want to point fingers on anyone other than myself for this. I installed an experimental image literally minutes after it was released and knew the risks. Now I’m just trying to find a way to fix it again.

What I will do:

  • Test the apps mentioned above
  • Make an issue on the UBPorts gitlab to see if they have any tips. Will post a link here when I’ve done so.

I’m hoping that what’s happened is that the Ubuntu Touch install makes some changes to some partition that isn’t reset on a normal FP4 Stock OS install, and that there exist some image or firmware somewhere that can be flashed to get it back. Fingers crossed :crossed_fingers:

1 Like

I just gave the internal test app a try and sadly the sensors don’t seem to work/produce any data during testing

Hope you noted the internal test app only works on the default Fairphone A11 OS and this topic is tagged for Ubuntu

I don’t agree with that conclusion. What I mean is that if we support 3rd software as if it’s maintained by Fairphone we also get all the topics with negative titles here. As a new visitor that gives the impression FP does a terrible job, we already have quite some topics of those. But you’re right it’s not as easy to make this distinction if it’s a true FP issue or quality/compatibility issue of another party.

But this suggests we should include any 3rd party software here? Although they do have their own forums/issue trackers. I think we somewhat should draw a line. But sure, this is a community forum, not official support. However, visitors are not always aware of that. Becoming a central hub for issues unrelated to what Fairphone brought onto the market might not be best for Fairphone. But again, this is just my opinion, I don’t decide these things.

My sugar coating comments were really not meant as a personal attack. I believe you bring this up quite often, while it really wasn’t directed to you or anyone specific. I also didn’t say it that often, or the internal search isn’t picking up “sugar coat @UPPERCASE” very well. I only see a few instances.

One of them is below. Where a reproducible issue is deflected with solutions and arguments that are not about solving the issue. Trying to make the issue seem easily solvable or not that much of a big deal. That’s what I call sugar coating :slight_smile:

I don’t want to sound rude but this discussion is making FP look bad and not the fact that users report that flashing Ubuntu Touch kills the working of sensors on the STOCK android image.

The only thing that is does is preventing users making the same mistake as we did and thus most likely resulting in less support calls.

We just want find help/support and not some internal discussion.

Yes this issue was caused by flashing a non-supported ROM, but it makes the device “unusable” on the stock android image. We are not blaming anyone but ourselves for installing Ubuntu Touch.

2 Likes

Posted an issue here: Installing Ubuntu Touch seem to break sensor firmware(?) when going back to stock Android (#27) · Issues · UBports / Porting / Community Ports / android11 / Fairphone 4 / fairphone-fp4 · GitLab

I’m pretty new here, so wanted to say sorry if I should have posted this somewhere else. But to me it was very unclear up until now what the issue was, and I would have completely reset my phone and sent it back for waranty repairs had I not gotten any answers. - Costing Fairphone time and money in the process. What I’m hoping to achieve is a solution for me and others who are likely to look here first for solutions to their issue. If Fairphone decide to silence posts like this because they “look bad” I think the only thing they will receive are more support requests.

That being said, I agree that the title of this post can be misleading, and I wanted to change it to “Phone sensors stopped working after installing experimental images” or something like that, to make the content more clear. But I don’t think I am allowed to edit it, probably because of my fresh profile?

2 Likes

This is the Fairphone Community Forum, so it’s naturally the place where most of the people with interest in Fairphone(s) will meet.

Part of being the center of a community includes, in my opinion, having discussions that pertain to maybe only the fringes of that community, otherwise we lose the connection to those projects. Outreach is a good thing.

People who are able to flash Ubuntu Touch onto their phone are usually also people who can help others that might have problems with stock FPOS.

3 Likes

That’s indeed something that has a place here. Please try the built-in FP test suite in the FP app. It has many tests for sensors.

Yes thanks. I did try that and the affected sensors sadly don’t produce any data.

If the issue is an Ubuntu one resetting the phone really means reinstalling the default OS. If that was done there would likely be no problem and so no ‘need’ to send it to Fairphone. If of course you couldn’t install FPOS and that is down to them then yes it is a bit of a liability for them.

As Fairphone don’t run this forum there is no chance they will silence posts etc.

Done: Is it OK ?

As stated initially:

After a lot of troubleshooting, as well as attempts to flash only parts of the FPOS offline installer (Divest devs suspected a driver/firmware issue), I finally gave in and decided to download and flash the full FPOS package, wiping everything in the process. But again no luck, not even after upgrading from the settings updater, multiple reboots and turning the developer option for sensors off and on.

Resetting and reinstalling the default OS didn’t help, meaning I could “play dumb” and send it in for a fix. But I want to try to fix this myself if possible, since all leads I can find points to some driver or firmware package not being reset by the default installer.

1 Like

Oh, and yes, thank you for changing the title!

1 Like