English

[Solved] HUGE problem - Boot and update to Android 10

Hello, I have tried for second time to reinstall the OS in my Fairphone, this time with the group of archives called FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage, and after reinstalling it, the phone got stuck in the booting screen. I have contacted the support team to see if they can fix this. I can’t try to reinstall the older version because I have already closed the bootloader and I can’t open it again, with this problem now I don’t have a phone, nice…

I tried the same. With the same result. There is a problem in the system.img file in the archive. Try pushing volume down and power for a long time to exit the boot (loop) and go to fastboot. Then install this update (https://fileshare.fairphone.com/link/LZMvdhZosMe1LgalvhXP3F). It’s not the lastest update, but the phone should be working again.

2 Likes

Perhaps this could still work? …

2 Likes

It worked! Thank you @AnotherElk and @Lorenzo1, but now when I start the phone it shows me a screen in which it tells me that my device may be corrupt. Is it due to using fastboot oem 8901_unlock?

I tried to do the reinstall process again with an Android 9 version but the phone still shows that message. I might leave this for another post.

PD: could the support team fix this? I don’t know if it is a thing to be worried about, and I don’t want to be 2 weeks without my phone due to this.

What’s the exact message?

If you mean the screen that just interrupts booting for 5 seconds and then closes automatically … that comes with unlocking the bootloader. It should have been there when you unlocked the bootloader before, too.

If you mean the screen where you have to press the power button to continue booting, else the phone reboots after 30 seconds … you can turn that off …

1 Like

Does this get rid of the problem or just the screen? I mean, the device will still be corrupt and with the secure boot disabled?

Again … What is the exact message on the screen?

Your device is corrupt.
It can’t be trusted and may not work properly, visit this link on another device: g.co/ABH
If power key is not pressed: your devicde will poweroff in 30 seconds.

PD: I mean, can I enable the secure-boot again?

Ok, it’s this 30 seconds screen then.

If this happened using the official Fairphone install file, following the official install steps thoroughly, then it’s good to contact support, they should look into this, it shouldn’t happen. You could wait for support to figure something out for safety’s sake.

Else … I got this screen several times when doing experiments with TWRP and install packages (before Fairphone offered an official one) and stuff.
Of course it hints towards some kind of problem having occured, but it doesn’t seem to go away by itself when the problem is fixed, at least not for me.
Once I was certain I got my OS install/restore right and everything worked fine apart from this boot message, I turned it off with ADB.
I didn’t experience any after-effects with the phone.

2 Likes

Yes, this happened using official Fairphone install file, the problem began with the new version (FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage). Thank you so much for the help, I hope they can fix this, because I am going to lose my phone for a while.

OMG OMG OMG, I installed Android 10 just to try and I got rid of that screen!!

FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage is Android 10.
So you did this before and it gave you the corruption screen.

It’s reassuring that if the install works as it should, the phone will be in a non-corrupt state.

But did you redownload the install file just now, or did the file from your first post suddenly work now?

1 Like

The corrupt state was given to me after I “fixed” the phone using “fastboot oem 8901_unlock” and reinstall the version @Lorenzo1 told me, the phone worked just fine but the corrupt state was given to me. Then it came to my mind the idea of updating it to Android 10 via the phone itself rather than an install file, just to test it before giving my phone to the support team… it updated as it would normally do, and the corrupt message screen just never came back.

2 Likes

Ah, I see now. Thanks.