[SOLVED] Fairphone Updater can't restart to flash Open Fairphone


I just bought a FP2 for my wife, and I can not install FairePhone Open.

  1. When unpacking the FP2, I did not create a Google account, knowing that I was going to switch to FairPhone Open. I did not put a sim card, but I activated the wifi
  2. I downloaded the file fp2-sibon-17.10.1-ota_from_gms-userdebug.zip and I filed it with my computer on the internal storage.
  3. As I do not have a google account, I do not have amaze file explorer, but I use the Settings / Storage and USB / Internal Storage menu to find my file and select it.
  4. Fairphone Updater opens it and suggests clicking the “restart” button
  5. But the button does not cause any restart, and the situation remains blocked.

To get things done, I tried copying the file to usb key or to an external SD card. Without success.

I checked the sha256, which is good:
sha256sum fp2-sibon-17.10.1-ota_from_gms-userdebug.zip
31e09bbc989ff4f08e81b0914b4f7c2507736b8c6f237c0abb3c4b9c940f7567 fp2-sibon-17.10.1-ota_from_gms-userdebug.zip

I have activated: Settings / Security / Unknown sources: Allow

When I launch FairPhone updater, it tells me Fairphone OS 17.10.1: your operating system is up to date.

Android 6.0.1

I do not know where to look …

Thank you for your help !

Initial text :

Je viens d’acheter un FP2 pour ma femme, et je n’arrive pas à installer FairePhone Open.
Au déballage du FP2, je n’ai pas créé de compte Google, sachant que j’allais passer à FairPhone Open. Je n’ai pas mis de carte sim, mais j’ai activé le wifi
J’ai téléchargé le fichier fp2-sibon-17.10.1-ota_from_gms-userdebug.zip et je l’ai déposé avec mon ordinateur sur le stockage interne.
Comme je n’ai pas de compte google, je n’ai pas d’explorateur de fichiers amaze, mais j’utilise le menu paramètres / Stockages et USB / Stockage Interne pour trouver mon fichier et le sélectionner.
Fairphone Updater l’ouvre et propose de cliquer sur le bouton “redémarrer”
Mais le bouton ne provoque aucun redémarrage, et la situation reste bloquée.

Pour avancer les choses, j’ai essayé en copiant le fichier sur clé usb ou sur une carte SD externe. Sans succès.

J’ai vérifié le sha256, qui est bon :
sha256sum fp2-sibon-17.10.1-ota_from_gms-userdebug.zip
31e09bbc989ff4f08e81b0914b4f7c2507736b8c6f237c0abb3c4b9c940f7567 fp2-sibon-17.10.1-ota_from_gms-userdebug.zip

J’ai activé : Paramètres / Sécurité / Sources inconnues : Autoriser

Quand je lance FairPhone updater, il m’annonce Fairphone OS 17.10.1 : votre système d’exploitation est à jour.

Je ne sais pas où chercher…

Merci de votre aide !

I’m not totally sure anymore but iirc this might be a permissions problem.
Try these two options

  • Put the file into the downloads folder and try installing from there.
  • Install Amaze (from fdroid, you should be able to download the apk via mobile browser and install the app), then use Amaze to open the zip file with Updater app
    One of both variants worked for me a few months ago, I just don’t remember which one… :frowning:
1 Like

Sounds like you might have an app installed that has the permission to create a screen overlay. If such an app is running install buttons and such are not working - that’s an android security feature. Don’t know if it’s the case for the updater too though.

Connect your FP2 to a wifi point, then open Updater. Long time I don’t see Fairphone Updater, but it had an option to install “other” OSes or something alike. It should list “Android” or “Fairphone Open”. Try to download it from there, and not manually.

1 Like

At least when starting from FP OS, that won’t work, the Updater does not provide an option to switch from FP OS to FP Open OS. The advanced mode you are referring to provides the option to download the full update instead of the incremental one.
I’ve been hoping for this option since the very first update Fairphone provided and checked for every single update since - in vain, unfortunately.


FP2 doesn’t suggest “Fairphone Open” to downlod… :disappointed:

sorry, FP2 doesn’t suggest “Fairphone Open” to downlod… :disappointed:

GOOD ! :grinning:
File was already in download repertory. It doesn’t matter.

But, after amaze is installed, with amaze browsing, when I select file, amaze ask for open with amaze or Fp Updater.
When selectinf fp Updater, the application FP Updater starts, but ASK PERMISSION to access to storage.
I just say YES, and problem is solved !

many thanks


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.