[Solved] Bricked FP2 screen is always black even in recovery

To anyone having formatted an internal SDCARD please start by reading _Chris response to recover your key then move on to CheckMorris post


I received my fairphone 2, a couple of weeks ago, I switched to fairphone open 17.10.1 using official updater. I experienced random reboots. The ISP I bought it from made me do several tedious procedures with no improvement.

I installed 17.10.2 when it was available things went better but still some reboots so I used the official installer to go back to Fairphone OS (1.13.0 ?)and things went very bad.

The screen turned black, the only thing that causes some vibration is the power button but nothing happens: screen is black, i have to remove the battery to be able to have the power button send vibration again. I can’t launch any recovery mode.

I removed my sdcard and tried with several os: ubuntu, windows, mac. There is no partition at all, I lost all the content of my previous phone.

Any advice ?

Don’t panic! :slight_smile:
The new displays don’t work with older versions of Fairphone OS. Just manually install the latest version.

If there was anything important on the SD card… that might be an issue. You probably formated it as internal storage. That means it is encrypted and can’t be accessed with anything but the system you formated it with. More details needed to help you with that.


If you formatted the SD card as internal storage do something else before following the steps in the link posted by @ChuckMorris:

  • Boot into TWRP without installing it (Download the latest TWRP version from here. Older versions will not work with a new display.)
  • Look for a *.key file in /data/misc/vold/ and copy it to your computer (e.g. with
    adb pull /data/misc/vold/).
    The *.key file can then be used to decrypt the SD card.

I followed the steps and recovered the phone thank you !

I was using the SD card as external.
I wanted to have an idea of stability before reformating it.

When I insert it in the phone and boot, it tells me it’s damaged and ask if I want to recover. Should I do it or can I use some Unix command/windows script to take an image of it ?



I had already done the recovery before your replied but the card was not installed as internal but external. (cf my reply to chuck).

1 Like

If you formatted the SD card as external storage it should have a single partition with a FAT32 file system. Reinstalling Fairphone OS should not damage it. You can use any Windows / Linux tool you like to try to recover it. You can also format it in the phone, but this will erase all data.

1 Like

If I plug my SDcard into the fairphone, its says the disk is damaged and I have to format it but will loose all data.

On windows, it just tells me I have to format it.

On ubuntu, I can see a /dev/sdc of 32M (my card is 32G) and no partition at all.

Sorry to say so but this looks really bad. Probably a hardware defect. Maybe this even caused your stability issues?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.