English

Software Updater fails on my Feb. 2015 batch Fairphone

Hi all,

I received my Fairphone from the last batch that was shipped this month (Feb. 2015). When I booted the phone, everything worked but the Fairphone Updater came up telling me that I run the OS version 1.5 and that I should update. I started the update and granted the Updater root access. It downloaded the software, rebooted the phone when the green Android came up and it looked like it installed the update.

When the system rebooted, the Fairphone Updater came up again, telling me that I’m still running 1.5. Even though there were no error messages during the upgrade process, nothing seems to have happened.

What I tried:

  • Deleting all the App data from the Updater and running it again. Didn’t help.
  • Upgrading to another version: 1.6, 1.7, 1.8 - Nothing worked. Still stuck with 1.5

I then thought I could just flash the latest image. But when I was looking for an image to flash, only version for the first (FP1) and the second (FP1U) batch of phones came up. Since my phone is from the third, 2015 batch, I had no idea what image to use.

Could you tell me how to get the updater to work or what image to use to update manually?

EDIT: Ok, I found out that those are also FP1U devices. But now I’m not sure what version to install. The tutorials are not clear about whether it’s ok to install 1.8 or not. Some tutorials claim that 1.8 is the latest stable version and others that it has been postponed.

1.8 has been postponed. (EDIT: as @Stefan explained two posts later the update is still available, but users don’t automatically get a notification to install it anymore)
1.7 was only pre-installed on some devices
1.6 should work though.

or you could apply for the beta-testing program for 1.8.2. it’s working quite well. most problems occurr when (re)installing google services, but i guess that was problematic in every version (i don’t know, i never did it).

1 Like

@paulakreuzer thanks for clearing up the confusion. So I’ll install 1.6 manually then.

Interestingly all the links in the tutorials still link to a 1.8 image to download:

So I figure this information is wrong, then.

1 Like

No I don’t think it is wrong. You can still download the image of 1.8, but it is no longer pushed to the devices OTA. Manual installation is still possible.

Ok, it’s not wrong. But if the software updater fails on the phones that were delivered in Feb 2015 out of the box (I just uboxed the phone and tried to update it) it sould at least stat what version is considered to be stable enough to install.

Well, to be honest, I would have expected the 2015 batch to come with a updated system anyway. Or with a working updater.

Well I can understand that, and I would have expected it too. On the other hand, I have installed Fairphone OS manually once or twice and it is quite straight forward (which does not explain why Fairphone didn’t do it for you…).