Software update: FP4.SP28.B.065.20230420

It is more like when you own a Mercedes Benz and you do not like the star logo in the front grill. Hard to fix that.

The Google search is part of what Google thinks a launcher from Google should have. If you do not like it, you will have to use another launcher, that is not provided by Google.


I must have misunderstood something, I took it so seriously that this is a bug and not a feature. So did I misunderstand that?

6 posts were merged into an existing topic: Wallpaper and style’ setting (Material You) missing in FP4 version of Android 12?

No update (I checked manually again this morning) for me. Fairphone bought in France but I’m currently in Iceland; I’m wondering if your actual location has an impact in receiving the updates ?

7 posts were merged into an existing topic: Wallpaper and style’ setting (Material You) missing in FP4 version of Android 12?

An additional change I seem to notice is that the Google search bar is no longer getting replaced by “At a glance”. It stays in place beyond midnight (rather than turning into a pumpkin :wink: ) Further discussion here.
If you disable the Google app, then in place of the search bar you get the “At a glance” widget straight away (requires reboot).

I have posted this info here, because it’s about a change brought with the sw update.

1 Like

So if I understand correctly this update will enable the feature and I have no way of changing or disabling it?
Is there a way to downgrade my phone to the previous version?


I applied this update OTA and my FP4 rebooted a first time, did something in background, rebooted again and keeps on showing the fairphone animation in a loop.
I tried a reboot (through keys combination and then choosing to reboot on system), but I get the same behavior again.
Is there a way to get this small update of 71.25 MB and apply this last via ADB?
I wasn’t able to find this small update.

Any hint is welcome.



1 Like

Now that you mention it, I rather think that my phone, when “restarting” just turned off and I had to manually turn it on. Sounds like there’s a bit of a bug in the package. It might be an idea for those who’ve not yet done the update to hold off pending a check.

@dom72 I think you should #contactsupport preferably by phone tomorrow.

You speak of using ADB: is your bootloader unlocked?

1 Like

Since the update i have issues with playing videos (youtube, twitch) in fullscreen. They fall back to small portrait video mode after every 5 mins. I tried updating the apps and restarting the phone. Anyone else have this issue as well?

This update is really annoying.

Please don’t ship half assed things that mess with our user experience this much.

Having UI colors force tied to the wallpaper is insane and should never have reached any users.

This is gonna make me think twice about installing future updates which is bad because security updates. But when you tie security updates to disruption of the user experience that’s what happens.

Please hotfix this immediately and stop pushing the update, you are playing with fire here.

And please don’t merge this comment with the other threads, this is about Fairphone’s update policy in general, not just this issue.

1 Like

This is a default Android development not one that Fairphone implemented, so you could try a different OS if you don’t like the current A12/13 and nothing to do with anyone’s ass :slight_smile:

But after buying into Google Android hmm ! careful where you pock your finger :rofl:

Clearly you are getting hot as I see a second post on this on another topic,


It doesn’t matter that it’s from stock android, Fairphone shipped it to us.

1 Like

I think that one or the other could have been done better. Pointing your finger is the most pathetic thing you can do. Other devices that also have Stock Android as already mentioned the Nokia devices don’t have these ridiculous problems.
So if you did it clean and right, it would be possible. A question of motivation or quality assurance?
I don’t know, but what you get for the money here is just a disappointment. With all due respect to the concept, you won’t be able to keep your customers without clean software.

“Change is in your hands”

Good luck then… I’ll use my FP4 as long as it runs, like any smartphone I’ve had. If Fairphone doesn’t work on its quality, I can buy a Pixel phone for the money. At the end of the day, it has to work the way it was sold to you.

1 Like

Updates sometimes are delivered at various points of time depending on operator (your network provider), perhaps this is the case with yours.

P.S.: Welcome to the community forum! :+1:

1 Like

My FP4 was updated through the 4G network to the latest update of FP, including patch of April 5th. My FP4 rebooted but then keeps on looping with the FP logo, and finally nothing happens.

I tried to re-apply the OTA update you mentioned but there’s an error message on FP4 screen:

Now send the package you want to apply to the device with "adb sideload <filename>"...
Supported API: 3
Finding update package ...
Verifying update package ...
Update package verification took 3.6s (result 0)
Installing update...
E: package is for source build SP25 but expecting SP28

Install from ADB completed with status 1.
Installation aborted.

I looked at some manifest files in the .ZIP file and found information related to this SP25. But not SP28.

Is this SP xx the versioning of the security patch?

I found this reference on lineage. Where the move from SP25 to SP28 is made.

At the end, I don’t know how to pursue with this OTA file.

My FP4 has the bootloader locked, and developer mode wasn’t enabled (my bad).

My only chance is to make this sideload work so that the FP4 can bootup normally, if possible.

Any hint is welcome.


That’s a reference to the build number:

The OTA update you downloaded expected the previous version (SP25), but your phone is already on the latest release.
The update did succeed but something went wrong and rendered your phone unbootable, which should have made it fall back to the previous version, which it didn’t.

I’m sorry, but you’ll have to #contactsupport, nothing we can do here :see_no_evil:

There have been several bricks reported for this update, someone should have a look at this! :roll_eyes:


Thank you very much for your quick reply. At least I know now that I can’t do anything myself to solve this. I’ll contact support as you adviced.
Again, a big thank you.

A post was merged into an existing topic: FP4 Root Access is possible, maybe a bit risky

I would count 2 so far, did I miss several others? I dont want to underestimate the risk and neither want to fear people too much.

Overall those 2 seem to be quite different, as here recovery is at least accessible, so what about a factory reset from recovery?

1 Like