Software update: FP4.FP4I.A.175.20221207

Thank you, is disabled. Does that prevent updates even after the 29 days period?

Still no vibration intensity option available and I still didn’t get a reply to the ticket that I opened on the 18th of december… :frowning:

The last ticket I opened said 5 to 6 working days (minimum)

Well the 18th was a Sunday so, 19, 20, 21, 22 we are only on day four. You’ll be lucky to hear much this year given 24, 25 26 which are weekends and holidays etc. etc. etc. 2023

1 Like

Yeah, not being home sounds like a good reason not to mess with the system :slightly_smiling_face:

The instructions are at the bottom of this post, once you need them.
If you have problems, you can follow up over in that topic.

3 Likes

Strange, I just noticed a couple of my FP4’s settings got reset after installing FP4.FP4I.A.175.20221207
This, or my phone is becoming sentient…

After installing FP4.FP4I.A.175.20221207, settings like “immediate fingerprint unlock” and “automatic WiFi switching” got reset to “on”. Other settings stayed put though, fortunately.

Did anybody else experience this?

Just a co-incident ~ I am just writing up on sentience and abuse but I’m sure the secret is communictaion and the phone is just a vehicle for the word of Google.

Dann kann man gespannt sein die bisherigen Updates gingen reibungslos über die Bühne! Weiter so!:rainbow::pray:t3:

25 degrees above freezing point are indeed a good reason for not beieng at home. :smile:

Is it really that easy? The process ist safe?

That was to be expected correct :slight_smile:

But they just got back to me saying the will recognize my support/feature request for future developments!

Thanks :slight_smile:

1 Like

It is, and it hasn’t failed me so far, but as always, wouldn’t try it without backups.

The updates frequently mess up settings. I also gave up on Firefox shortcuts on the home screen. They are removed with every update. Also other settings sometimes get reset. Best is to #contactsupport.

I didn’t notice any settings getting reset this time though. But it happens.

Sure. As long as (worst case) there is a way back if it fails…

Oh no, it’s really just a minor annoyance.
I was just wondering if it’s something “normal”, or if there was something wrong with my phone.
Now I know that after an update I’ll have to check the settings, that’s something I can live with (even more if there is any kind of pattern on what gets reset). Thanks for putting my mind at ease!

(BTW, FWIW, I had Firefox in one of the 5 ubiquitous bottom buttons, and it did stay put.)

1 Like

Good to know Firefox shortcuts remain now. But it’s not normal and to me is an indication of something that may one day cause major issues after an update. I hope they’ll improve. It definitely is not something Google does. I had a Pixel for 3 years, updates went smooth and did not change any settings for me.

That’s not the point. It’s a shortcut to a website, you placed on your home screen, that might disappear.

I guess it’s the pixel devs taking a little more time to make sure they don’t enforce settings which might have been changed by the user… As opposed to just throwing in the standard config files and overwriting any existing user modifications.

2 Likes

Here’s a link to the ota.zip if someone needs it.

No issues with the Magisk OTA update procedure, everything worked fine, as expected.

@formerFP.Com.Manager Could we please get updated factory images for this release :pray: the install script of the available ones has been broken for months now … :roll_eyes:

6 Likes

Here’s a link to the ota.zip if someone needs it.

Hi, do you have a pointer to get infos how to use this? I am quite new to the FP community and some additional info I would appreciated very much

Sure :slightly_smiling_face:

  • you’ll need adb installed on your PC
  • connect the phone via USB
  • run adb logcat -c && adb logcat > logcat.txt to capture a log
  • start the OTA update on the phone and wait for it to download something
  • look for for a URL containing googleapis in the log
  • (optional) try downloading it, e.g. with wget and check the content
  • that’s your link to the ota.zip :tada:

Edit: Aaaaahh, you meant what to do with it, not how to get it :man_facepalming:

You could use it to update the system through recovery, but my main reason to share it is because you can use it to create updated factory images if you combine the ota.zip with the previous factory images using something like payload_dumper.

2 Likes

Hi,
just changed to FP4 recently.
Can’t get the update in though, update always fails without any details, logs,…
INet-Search also shows no tips.
What is the right way out there?
Is this maybe a weird combination of preset & country (I have a “Magenta” app preinstalled&undeletable but in Austria Magenta does not even sell them)?
Reset to factory?
any help highly appreciated.
thanks in advance,
Bert