Software Update: 8901.4.A.0013.4

Just tried it, and this works for me as well! Although I don’t have a clue why the 3G/4G didn’t work properly in the first place…

Just not for O2 in the UK. Still have to keep Wi-Fi calling off and 4G calling off, otherwise all incoming calls are “Unknown number”. One day I’ll get round to reporting that to Fairphone support!

No other problems so far…

Having had a look around it seems to me that this problem is often a fault on the carrier’s side, and it can affect subscribers individually. [As well as contacting FP] I would advise you to contact O2, and make sure that they grasp details such as the fact that the problem occurs when using 4G calling.

Resolved cases tend to state things like “the carrier reset my subscription” or similar, or just have no further discussion after a carrier’s rep intervenes.

1 Like

Would love to see IKEv2 vpn support in the next update :pray:

Is this any use ?

It’s definitely possible to do IKEv2 with third-party applications. What I was really keen on was trying the native IKEv2 support that is possible in Android 11. It’s supported “out of the box” on most Android 11 installations, but the Fairphone images are not yet built with the new IKEv2 libraries.

I have previously created a support ticket about this, and after a long delay, I got the response that it was a known issue and that some future update should include it, but there were no commitments as to when it might become available.

1 Like

The update apparently also fixed something on the wifi hotspot as my Tesla is now able to connect to it

1 Like

Just took the phone apart with a friend, and found out it is a hardware problem. One of the pins connecting the “motherboard” to the screen is depressed, and seems to have been so from factory, and it has now lost connection. If I press the phone hard precisely where the pin is malfunctioning, I actually get an image for a short while.

You can, with care, apply a little bit of solder to the depressed pin or the opposite part to enbale them to engage. You can ask a repair shop to do it.

I had the issue with “Full SD card” that is mentioned in the OP

We’ve fixed a minor issue on the stock camera app that, under certain conditions, was causing a misleading warning saying “Full SD card” to appear while the actual storage was the internal storage.

Not sure if was the same root cause as no storage was anywhere near full. This phone does not or has never had a SD card installed and the free space on the internal storage is > 16 GB.

This update did fix the issue, making the camera usable again - but alas only for one day. There is now a message reading “You are running out of space. Change the quality setting or delete some images or other files.” with the stock camera app - so different from the “Full SD” message before the update. Any ideas how to fix this?

Hi and welcome to the forum…

You may try clearing the camera Storgae and Cache. Settings > Apps and notifications > SEE ALL ## APPS > Camera > Storage and Cache . . .

Try clearing the camera app’s cache and data (this will not delete your photos)

Settings > Apps and notifications > See all apps > Camera > Storage and cache
Clear cache, then Clear storage.

Thanks @OldRoutard and @amoun . Unfortunately clearing cache and storage did not solve the problem.

So how much memory do you have currently?

Are you using the default Camera app? I wonder if it would be different if you use Open Camera for example ?

Did you restart the phone? Shut down then turn it on again.

1 Like

16.7 GB free. Stock Camera is default camera app, but also have GCam mod installed - which is able to take photos and video. As GCam is quite unreliable I’d like to have stock app working. Also just tried OpenCamera which also works, but is not really a replacement for stock…

Thanks again, but shutdown and boot did not change anything unfortunately

What GCam do you use? I use Nikita with no problems for the best part of two years …

Would that not invalidate the warranty?

I have never had the need to take my FP3 apart so don’t know if the pin in question eminates from the mainboard or the screen. I’d be more inclined to gently bend the pin that is out of alignment over solder, but I’d only do that if the pin was attached to the screen as that is a replaceable item. If under warranty or if the pin is attached to the mainboard, I’d send it back for repair.


Hooray! Very glad to have the option to save photos to the SD card again!

The improved dimming is also super welcome, though it would be good to have it even dimmer than the dimmest it is at the moment. But it’s a very good start :slight_smile: