Soft Bricked FP2 - Stuck on Fairphone logo after failed OS installation

Hi everyone,

I bought an FP2 in second hand last January and I tried to install a .zip through TWRP, but with this manipulation, I bricked the Fairphone. In fact, the phone don’t on an OS, I’ve just the Fairphone Logo on the screen and nothing else.

Before tho ask help on this forum, I read this topic: Hard-Bricked FP2 and many others, but I don’t found the solution to repair it.

I tried the following things:

  • Enter the recovery menu (Volume up and power)
  • Enter the fast boot menu (Volume down and power)

But I can’t access anything.

I also try to access the phone with fastboot but I have this error message:

device unauthorized. Please check the confirmation dialog on your device.

I wanted to check if someone can help, otherwise, the phone is still under warranty but I don’t know how to contact the support.

Can you help me?

You can submit a support request, find their phone number and office hours (at the very bottom of the page) here:

If you have problems submitting the request through the form, you can email it to instead.


The device unauthorized looks more like an adb message than fastboot, I’ve never seen that in fastboot mode.

Basically, using [Power] + [Volume down] for fastboot brings you to a black screen with Fairphone logo (that’s how the phone looks in fastboot mode). But then, with the command fastboot devices you should be able to see your phone in your terminal.

As I said, “device unauthorized” is new to me in fastboot mode. Can you confirm that you get this message when you try what I explained above (i.e. using fastboot devices command in fastboot mode)?


Thanks for your replies.

@urs_lesse Ok the zendesk, I keep the link in case I can’t repair it.

@freibadschwimmer You’re right, I have confused abd and fastboot. fastboot detect the phone.

f744b6ba	fastboot

And I’m trying to boot on an .img file from a backup with this command :

fastboot flash boot boot.img

But the < waiting for any device > message has displayed for a long time (about 15 mn)

If you’re on a linux machine, you might need sudo before fastboot commands.

Thanks, I forgot it and it works

target reported max download size of 536870912 bytes
sending ‘boot’ (13720 KB)…
OKAY [ 0.431s]
writing ‘boot’…
OKAY [ 0.314s]
finished. total time: 0.745s

But… it’s worst. I try to reboot it but no more Fairphone logo, I’ve just a black screen and the red LED on the top.

If you used a proper boot.img, then it looks like it should be fine.

Red LED could be an indicator that the battery is empty. You could try to give it some time to charge, maybe the phone is just low on battery.

You’re still right. (Sorry for the Pecbak error)

Meanwhile, the phone is charging, I have few questions to ask you.

In my Backup directory, I have a “fp2-sibon-16.12.0-manual-userdebug” folder which contains three .img in an “AP” subfolder.

  • boot.img
  • recovery.img
  • and system.img

Do I launch fastboot with these three files?
Is there an order to apply them.

I found the response to my question. (=> !|RTFM]( I’ve launch the (with sudo :slight_smile:) and t works.

Thanks for your help.

Great to hear it works again!

Since the phone wasn’t hard bricked, I changed the topic title, so people can find it easier or won’t get confused if they search the forum.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.