SIM - 'No service' - what's going on?

Hi, My FP2 (two weeks old) has been working fine until this afternoon when suddenly the sim said ‘no service’. I tried the sim in my old phone and it’s working fine. Tried it in the FP2’s other sim port and same problem. Done all the obvious stuff (off/on, wiping the sim, etc.) Can anyone help?

Did you already try another SIM in your phone?

I only have one sim. It works fine in my old phone…

Ok it’s working again! I have no idea what happened, but all seems fine now… ?!

Could it be the network reception of the FP2 is just not as good as other phones? It could also be the reason for topics like this one: Sim cards lose connection to the network.
I also sometimes loose network connection when I’m at work. There is a weak signal in the building, but my FP1 never lost connection…

1 Like

I bet this is a Vodafone-net-SIM. Cause Vodafone yesterday ha a server-failure …


It’s not Vodafone - is 48, daughter network of Three in Ireland. Friends use same network and their phones were fine while mine was down, so defo a phone problem.

I have to live with a lost bet ;-(

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.