SIM 2 can't be unlocked after encryption - blocks startup [workaround inside]

Hi there,
I recently encrypted my FP2 and now I’m no longer able to unlock the second SIM.
As I only use it for 2-factor-auth this is not a problem for me, but I think the bug in general
is rather significant.

The 2nd SIM was in the phone when the encryption took place.

Now when I boot up the phone I can unlock SIM 1 OK, but on SIM 2 I always get an error that the
unlock operation failed.

The SIM is not locked. After 4 or 5 failed attempts I put it in another phone and the unlock via the
PIN worked without issue.

The phone is protected with a lock pattern.

Just wondering:
Did you try switching the SIMs around (SIM2>Slot1 SIM1>Slot2)?
Did you try to switch the phone on without SIM2, shut it down again, and retry with SIM2 present?
It seems there are some more issues with the handling of SIM2 (e.g. here), hopefully Fairphone will address this in a software update…

I tried indeed to do this.
In fact the issue seems not to be with the card, but the slot.
Both cards work fine in slot 1, if no card is present in slot 2.

Several restarts did not change the situation.

It seems to me that the several overlays between

  • Unlock SIM 1
  • Unlock Phone (pattern)
  • Unlock SIM 2
    are not handled in the correct order.

Interesting behavior. Though, i cannot reproduce the issue. I’m using dual SIM on an encrypted FP2 since months but never run into that problem.

Have you already tried to disable the PIN of SIM2 in another phone or in slot 1?

Is your Slot 2 disabled? May be this issue here:

Yes the slot 2 is disabled.
Actually removing the PIN on SIM two worked as you described it in the other thread.
This is definitely a bug that needs to be fixed :frowning:

A post was merged into an existing topic: SIM2 disabled but unlock screen does request for pin (after reboot)