Silent call and failed proximity sensory on new Fairphone 2 and support form broken

I’m quite upset at this point, I bought the Fairphone 2 from the Phone Coop in the UK and have had serious issues with it. The proximity sensor has been buggy for a while - not turning the screen off when against ear/in pocket, leaving screen black and non-responsive if I take phone away from my ear sometimes taking 30 seconds+ to come back to life.

Then, less than 2 months after purchase there became serious issues making calls, the mic doesn’t seem to work at all unless I put the phone on speaker mode at which point the mic works but I can barely hear the other person despite holding the phone to my ear, very quiet. This is clearly a major bug and I tried to contact support last Monday. The form wouldn’t submit at all as a fault, just sent me back to the same screen with those options selected, I finally after many attempts got it submitted my sending it as an other issue rather than a fault and have yet to hear anything back.

I’d appreciate any advice, I’ve tried plugging and unplugging headphones as well as a hard reset but i suspect the phone has a hardware fault (or two) and I need support to actually get in touch and fix the darn thing which I’ve now been waiting a week for them to even respond. I’m in the UK and don’t know what it would cost to call abroad but am considering phoning just to get it sorted.

To add insult to injury I’m disabled and my mobile is a lifeline in terms of communication and I need it to work desperately not be waiting weeks for it to be fixed.

I am/have had the very same issues, how did you fix them? Sensor has to be wiped at least twice a week and no one can hear me on calls :frowning: phone has been great otherwise but it’s so annoying

I haven’t! I’m still waiting for any contact from support and have tried everything I can think of including a hard reset and checking everything is properly connected, very frustrating.

Have you already tried installing the newest FP OS 1.6.2 update from the Updater and calibrated the sensor from Settings > Maintenance (a menu option which appears after installing FP OS 1.6.2)?

Yeap, plus hard reset all to no avail.

Also tried reset and downloaded update :frowning:

I’m having the exact same problem with the phone calls. the people I’m talking to can only hear me when I put the phone on speaker mode. is there any solution for this? it seems to happen only since I updated to 1.7.1 - I had 1.3 or something before? it was quite a bit lower because I have to do manual updates and hadn’t done one yet.

Sounds like a broken micro. Try to take out the bottom module and put it in again, otherwise you may need to get a new bottom module. I doubt it’s related to the sw update, this is more likely a coincidence.
See this thread for more info:

and particularly check out this site:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.