Settings < accounts < google < 'sync calendar' is gone

My dad told me to use ‘Clean master’ to get rid of things I wasn’t using on my fairphone.
I threw some things away but I think I got rid of too much.
I deleted the native calendar and another thing. I can’t remember what (it had to do with the native calendar). Just because I wasn’t using that app but the ‘google calendar’ app.
After getting rid of that, the ‘google calendar’ app wasn’t working anymore.

I tried several things. I did go back to the factory settings, I did a hard reset. Nothing is working.
Then I found out that if you go to the settings < accounts < google I see a lot of things (contacts, gmail,…) but the ‘sync calendar’ option is gone. I think that’s why the calendar isn’t syncing?

I hope my question is a bit clear? Anyone out there to help me?

If you go to ‘apps’ (by swiping from right to left and then tapping on the circle with the six dots) can you find there the app ‘Calendar’. If so, to ‘settings’ and add your account.

If the default calendar is not their, you can always download it from f-droid: [quote]Standalone Calendar (AOSP calendar) -[/quote]

Fixing it with the f-droid thing wasn’t helpful for me. Just installing the calendar app wasn’t enough. After two days of searching I found a solution by just using common sense.
I used the Fairphone updater. I already had the right updates for Fairphone OS and Stock Android. But after reinstalling Fairphone Cherry 1.6 (go to the Fairphone updater, click ‘Fairphone OS’, click ‘Check details’, click ‘download and update’ and just reinstall. All the lost things are back. I’m happy again. :smile:


Glad this fixed it for you.

My advice would be not to delete any of the system apps :wink:

This topic is now closed. New replies are no longer allowed.