Setting Time does not work

Hello everyone,
I just got my new Fairphone and it doesn’t want to change to the correct time. I chose the Setting “Automatic Timezone” and the right timezone is even displayed, but the date and the time don’t change into the actual date and time. A restart of the phone didn’t change it either. Any suggestions?
Thanks, Ina

Alright, so after one hour waiting, date and time are now correct!

1 Like

I am using the free App ClockSync
Even on travels the free TimeZoneDB for ClockSync is adjusting the correct time easyly and fast.

Kind regards

I have noticed this occassionally when changing timezones you’ll get a new signal from a provider but it won’t take the time from the provide. However I don’t think this is just limited to the FP, I had similar problems with my old HTC.

Usually they self correct without interference.

Another possibility to adjust the time is the tool Global Time that uses the time signal from the GPS.

Kind regards

If the phone didn’t change time settings at end of daylight saving time I wonder if the solution might be a simple reboot? If the phone has been constantly running since before Sunday morning, it has probably kept the time settings retrieved at last boot.

I have got a similar problem! After being to Ireland (where the change of time zones worked absolutely fine) I returned to Germany and now my phone clock is five minutes early. I don’t find any possiblily to set time manually and all attempts to set the time right failed: rebooting, set the time zone etc. Any ideas what I could do to get my phone back to correct time?
Thanxs a million!

I had the same type of problem yesterday, for some reason the date and the time were wrong… Did find how to change all that manually, but it took some time to find.

Here is: You must go the SYSTEM SETTINGS
There, you must make sure that AUTOMATIC DATE TIME is OFF
After that, you are allowed to set both date and time.

Thats correct.
Or you can manage the time correction with a App like ClockSync
When you save Energy using a tool like No-frills CPU Control your clock will never be exact and its recommendet to adjust twice a day the clock with a ClockSync App.

Best regards

i have a similar problem; but when i turn off the automatic time settings, the manual time and date setting options remain greyed out, there is no possibility for me to adjust it manually …

Please don’t do cross-posting to avoid that discussions are going on in different places!