Screen can not be activated by pressing the power button


My FP2 is 7 months old and I already bought a new battery.

The screen stays randomly black when the phone is on and good battery level. And I have a yellow LED light.

Nothing happens when I push the power button, also for 10 sec. So, I have to open the phone, take the battery off and put it again in order to re-start the phone.

Somebody has a solution?

Thank you!

I moved your post here according to the #blackscreenguide.

To rule out a hardware issue please take off the screen and carefully clean the connectors.


I received a new fairphone after having to return the first one with the “random reboots” issue.
The new one seemed to work just fine until I found out there was the blackscreen issue.

Randomly, the screen turns black and it’s impossible to use the screen for the next 5-10minutes, tho I can use the buttons (for instance, I took screenshots).
If it blacks out while I’m using it, the screen turns bright and makes a flash before turning black.

I have tried wiping the cache five minutes ago but it didnt do anything to the blackscreen issue.

Has anyone found a workaround for this so far ?

Follow-up i dismounted the screen today to clean the connectors.
The blackscreen was back as soon as I turned on my phone.


I have a very annoying problem with my FP2. Several times when I want to use my FP2 and press the upper right button my screen won’t come back. The FP2 hasn’t shut down but there is no possibility to acces the screen the only thing I can do is remove the battery and restart my FP2.I have the latest OS-version. What is the problem here?


I have the same problem as described above. Does anyone know if a solution to it has been found?

@Cjohnsonlives, @langga, @laurevdl, @Nordsman, @Flor, @Clement, @Jonas_Gruska, @BauAC, @HannSche, @tkos, @faltpihl, @Bart_Mertens, @mike2, @corngep, @shwilson, @dbrgn

Please try uninstalling the Facebook App if you still have this issue.

Does that solve it?

  • Yes (No more blackscreens without the Facebook App)
  • No (but it’s better)
  • No (No changes)
  • I never had the Facebook App and still have the issue
  • The issue solved itself for another reason.

0 voters

If it’s indeed FB related you can continue here:


I don’t have the facebook app. Even never installed it (and probably never will :smile: )


I had the same problem a while ago. First I thought it would be an app related issue, so I uninstalled quite a few apps - but without success …
I discovered that when I slightly moved the screen up and down towards the casing bevore turing on, it worked. So propably a contact issue, but all cleaning didnt’t help.
Some weeks later my screen started to behave like “dancing”: some elements were flickering, the notification/settings bar from top came down by it self and could not be swiped up again. Few days later a part of the touchscreen on the right stopped responding.
I contacted support and received a new display module - now everything is fine!

Happened 5 times this week. I found my FP2 not resuming from sleep and only way to make it back working was to keep pressed the sleep button more than 15".
I conclude it turned off itself.

Any similar case ?

Based on your description and the black screen guide, I’ve moved your post here.

I have had the same problem since last android update. Start button not responding sometimes, in no particular case. Screen staying black and unable to use the phone for several hours. I had to reboot the phone until, for any reason, screen started to display again. Very very serious issue!

The issue occurred once or twice everyday, until : I uninstalled Facebook and deactivated Localisation. I don’t know which one has worked, but I’m relieved. The issue did not occured in 5 days (after one last reboot).
This might work for others.

Sadly, the problem did not occur during one month and then came back. Some days I can only access to my phone during 1hour. The rest of the day is spent trying to display anything/reboot/learning how to live without a phone. That is not what I expected from Fairphone :frowning:

I have this issue with a new screen I just received after my old one went haywire. I run the latest OS 18.03.1 and just hard-reseted the phone to rule out software issues. When I removed the screen and reassembled it several times, I realized that looking from the side, the screen looks slightly bent upwards at the upper half (i.e. away from the connector pins). I then tried to press the screen towards the chassis when the blackscreen was there and it seems to work most of the times. So in this case, it indeed seems to be a connector issue, but not because of dirt or oxidization, but because of lacking contact. The problem is that I need to press the screen down every time I want to activate the phone, so this cannot be a permanent solution. Anyway, can anyone confirm this?

Here is a video which shows the problem and its “solution”

Same problem here, screen stays black every few days. Reboot is the only solution. The phone otherwise seems to work somehow (my pc still recognizes it, the led is still flashing for new messages, etc). However, phone calls do not get through. I might be biased, but this seems always to happen after some notification pops up. At least this happens very often after it vibrated for something and than I cant take the screen on. I am not sure if that is only a situation in which notice the problem or if the notification is causing the problem. Notifications that usually pop up in this situation are “calendar event reminder” and “tasker” notifications.

Hello Guys,

i have the same problem. It is totally annoying. Tried all the solutions which are written in here. But I have still the same problem.

Does anyone know what to do? Should i sent it back to be repaired ?


I had this same problem. Last Monday I removed the screen, wiped all the connectors clean (not only the big one on the right, but also the smaller ones), and then put the screen back. The problem hasn’t occurred anymore since then. So that seems to have fixed it for me.

Unfortunately I have the same problem but no solution yet…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.