Scanning QR code, microphone and headset issues

Dear all,

since sometime, my FP2 bugs more and more often when I want to scan QR codes. I thought it might be the proximity sensor, or maybe the luminosity of my computer screen, but to no avail. If it doesn’t want to work, it doesn’t; the image remains flue, and the camera doesn’t scan.

Another bug is the micro - I need to participate to some videoconferences by phone. I’m a Linux user, thus banned from Webex or Skype for Business, and I usually get around this by using my phone. Unfortunately the micro is so bad that this option doesn’t really work. Micro is fine for talking on the phone, though!

In order to get rid of that problem, I bought a headset and also downloaded the JBL app - but what happens? Phone doesn’t recognise the headset. I wonder if that is because the plug doesn’t get a contact?

If there are any updates to do, apps to install/ de-install, whatever can be done on the operating system, spare parts to change that would help me to resolve these problems, I’ll purchase them willingly. I need to buy a new battery anyway. FP2 is 5 years old, and if I can get it working, I’ll keep it for another 5 years…

Thanks a lot for any help,


1 Like

It’s a little bit difficult to understand what is wrong actually: When scanning QR codes you need a functioning camera and a QR scanner app. The proximity sensor doesn’t have to do anything with this. From what you write it sounds like you want to capture a QR code from your computer’s screen and the camera is unable to get it sharp and therefore doesn’t recognize the code. Is that correct? If yes: Have you tried increasing the size of the QR code? Does the camera work for its actual purpose (taking photos) or are the photos useless, either? If the camera is broken a new camera module could help you.

About the microphone: Could be that something is broken of course. Could be that Skype and Webex use the top microphone and this is broken while the bottom mic which is used for normal calls isn’t. Have you checked this with the diagnosis tools provided by Fairphone? They can be found somewhere in the settings under System if I remember correctly (don’t have them installed on LOS, therefore cannot look it up).

Since it sounds like your headset is a wired one there are only few chances why it doesn’t work at all. If the phone cover is preventing the plug from being inserted far enough you can check this by removing the back cover and trying it again. For a wired headset you shouldn’t require an app. In Fairphone OS there should be a headset icon in the notification bar if the phone recognizes that something is connected. If it still doesn’t work you could try simple headphones to check if the headphone socket works at all (plug them in, play some music, can you hear it?). If that isn’t the case a new top module might be the solution. You could cross-check this with someone living close to you and having a FP2, too, by exchanging modules.

Please let us know what you find out.


Regarding the headphone:
If my memory serves me correct, there are different plug standards (CTIA / OMTP).
And FP2 is supporting the CTIA standard.
If that should be the reason for the headset not working, an adaptor might help.
You might have a look at this thread/posting:

I have no idea, what standard your JBL-headset is supporting, but maybe your manual will have some info on it; or you could ask JBL support?

As a small consolation, you were awarded the well deserved badges for 3 / 4 / 5 years Fairphone 2.


Dear Bert and Martin,

thank you so much for answering so quickly. I somehow thought I’d be notified by an e-mail when getting an answer, so after 1 month of no answer I looked up the forum and found that two people answered…Sorry for that lack of regard,

So I took your advice and found the test modus for the microphones. Phone microphone works fine, the other so-so. It works, but noise level is much lower. But I resolved the headset problem, I just connect it via Bluetooth and forget about the wired connection. So I wouldn’t really NEED the microphone.

If I plug the headset in, however, it is very weird. I hear a very, very faint sound (the song it should play, not some outside sound), but there is no way to get it louder.

Remains the camera problem. When I need to scan a QR code (no separate application, the mobile payment application of my bank), it’s exactly what you said, Martin. The camera doesn’t focus. I tried to make the QR code bigger, increase luminosity, whatever. It simply doesn’t work. Then, some days later, in another context, it DOES work.

Camera normally works as always. It refuses to focus sometimes, but that is really rare.

And Bert, thanks a lot for the badges - I’ll wear them proudly in front of my children who are always sporting the newest rotten apple or galactic products.

Best regards,



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.