Sailfish OS beta4 release

Sorry for the delayed answer. In linked post it says that Halium 7.1 is not ready for FP2 and Halium hasn’t really been used as base for Sailfish OS for some reason. I could of course use Lineage OS as base for FP2 port of Sailfish OS but decided originally to use the official AOSP base. There isn’t that much difference which base to use, I could test how latest supported Lineage OS works as a base, it would probably take only a couple of hours to make a test build with all features working.


Thank you for your work!! Since my last google-free smartphone with OS Symbian Ana, many years ago, I am looking for a smartphone with Open Source. I want to install Sailfish on my FP2, but I am still not sure I manage. I am looking for all relevant information on the forum.

1 Like

According to ✏ How to install Sailfish OS alpha on the FP2 the current installation documentation can be found at

1 Like

As mentioned in previous comment the installation instructions are in Mer wiki. The simplified version is the following:


Thanks for the great effort!

Is there any chance that Sailfish OS will maybe be officially supported instead of community editions?

1 Like

It’s very unlikely. There were talks (see here), but it all went quiet.


Hello Volker,

I do not want to bother mal because I am quite the beginner.

I reached the first step and have now Android 6.0.1 (18.04.1 release) on a brand new FP2. I installed adb and fastboot in the terminal of my Ubuntu laptop. Now I am stuck because ‘adb devices’ returns only ‘List of devices attached’ and nothing else when I link the FP2 by USB cable (choosing ‘loading mode’, not ‘data transfer mode’).

I read that I need to switch to debugging mode but I could not find how to do this on my FP2

I really want to succed myself because I find it important that not only computer nerds can use FP without g00gle.

Have you tried to run fastboot resp. adb using sudo command? And your phone has to be in #dic:fastboot mode.


I forgot ‘sudo’, stupid me.
The second part of your answer is the answer I was looking for. I will try again this afternoon.

1 Like

The adb command did as before, but ‘sudo fastboot devices’ returned ‘c2e5454f fastboot’. So I followed the process as written in the Mer Wiki:

  • Extract the files from the zip
  • Go to the folder you extracted the zip
  • Check that the device is detected with fastboot devices
  • fastboot flash modem ./BP/NON-HLOS.bin
  • Extract filesystem images from Android zip on your computer.
  • Enter fastboot mode on your phone by turning off device, when device is powered down press and hold volume down button and then plug USB cable.
  • Open a terminal on your computer and go to the folder where you extracted the file system images.
  • Check that the device is detected with fastboot devices
  • fastboot flash system system.img
  • fastboot flash recovery recovery.img
  • fastboot reboot

It seemed okay, but following the reboot (which had some hickups but managed in the end without me doing anything) it has been nearly two hours showing “android is being updated - Settings are being prepared”.
While waiting I found the Fairphone Installation guide for Open OS where the package name is the same as the one on the Mer Wiki except it has “switcher” in it: fp2-sibon-18.04.1-manual-switcher.
I switched the FP2 off now because I am thinking of trying the process stated on the Fairphone guide, but it will not stay off, it is in a loop: starting until “change is in your hands”, and starting anew until…
What do you think?

I think the instructions on Mer are a bit confusing. The only file you use from is NON-HLOS.bin (notice the instructions for this file are all sub-points; the instructions them jump back up a level to refer to 18.04). If I read through what you did, I get the impression you also used system.img and recovery.img from If this is the case, the best way forward would be to follow mal’s comment above:

In short:

  1. Install Fairphone Open OS / Sibon using fastboot and this file: You can use the Fairphone instructions for this, as mal mentions the whole installation can be done.
  2. Unpack, and flash the NON-HLOS.bin file that’s part of the extracted data via fastboot. fastboot flash modem ./BP/NON-HLOS.bin looks okay as a command, though I’m not 100% sure of the exact path.
  3. Continue from Sailfish OS installation in the instructions on Mer Wiki.

After restarting, the phone stated (as in the first round) ‘optimizing x apps out of 72’, which took some time, and now it is again ‘android is being started - Settings are prepared’.

I am running out of time, I will leave the phone on for another 2 hours and then switch it off and continue at the weekend.

@mal: I would be happy to test and report issues if you have a build with the latest Lineage OS as a base ready. Pretty eager to do it…

sorry, I sent my reply before I saw your post.

No, I did only the one command fastboot flash modem NON-HLOS.bin from the directory with the unpacked[].

What I did wrong is to do step 2 first, and only afterwords did install Fairphone OOS (step 1) because in the beginning I thought I already had that. However, to do step 1 (following finishing step 2), I started from another directory with the unpacked fp2-sibon-18.04.1-manual so I used this unpacked file for system.img and recovery.img. I have screen shots but I do not know how to put them here.
I will start the whole process again at the weekend, this time starting with step 1! Over the years I learned that with computers, you need patience and try again.
Thank you for your help up to now! I will switch my FP off now, it is still struggling to start android…

1 Like

I have been thinking, it seems to me that my poblem starts right when the command line ‘sudo adb devices’ and ‘… fastboot’ don’t return the FP (but only the SD-card which I put in the FP). Now I found a good thread for me (it’s in French, sorry) at: 🇫🇷 Mise à jour du FP2 vers Open Fairphone OS impossible
I will follow this up at the weekend.
I am really happy about this forum, thank you to all those who contribute!

1 Like

Actually, you don’t need to boot to your OS at this point! Once you flashed the system.img and the NON-HLOS.bin, just reboot to TWRP recovery and install the sailfishos zip.


As Fairphone announced the next beta with a lot of bug fixes (e.g. switching off with new camera modules and so on), a build.on the basis of the coming version could be a good idea.

1 Like

@mal I am.using the port for several days now and I have a huge battery drain. Top/htop shows that there are processes

/usr/sbin/sensorfwd -c=/etc/sensorfwd/primaryuse.conf --systemd --log-level=warning --no-magnetometer-bg-calibration

These processes use 10…15% (according to htop), battery drains fast and the whole system feels somehow slow, e.g. characters show up with a short delay after typing and so on.

Have I f***** up something?

Did you correctly flash the old modem partition as mentioned in instructions:

  • Download
  • Extract files from the zip and locate file NON-HLOS.bin
  • Run as root: fastboot flash modem NON-HLOS.bin
1 Like

Thank you! I’m 99% sure I did it, but just to be 100% sure I did it again and will check it’s behavior over the day.