Sailfish OS beta3 release

@pa4wdh : Now i have reinstalled my Fairphone 2 from scatch.
First Android 18.04.1 (and gms59.1.5.1 modem part) then SailfishOS Beta3, as described on the wiki.

It seems that me problem with the SMS on the Telekom sim is really a sim (or Telekom) problem, not a Phone or OS problem (i have to talk to the Telekom support).
I tried sending SMS with Android, switching the sim cards on Android, but the problem stays with the Telekom sim :unamused:. I get an error 21 sending an SMS (what ever this meen …) and did not receive a SMS sent by and other sim.

My problem with the mobil connection vanished after the new installation of the SailfishOS.
Switching the sim for the mobil connection requires a reboot of the phone, but both sims work.
Maybe this problem did not not occur on your phone because you use two sims with the same provider …

So i think an update should be no problem on your phone :wink: (but always backup your data …).

5kup : on TWRP you have to disable the MD5SUM check, then it should work.

1 Like

I know the instructions on wiki can be a bit confusing for some people. I can modify the instructions if anyone has suggestions how to make those better.

1 Like

Thanks for your update @gabs, i guess I’ll just have to try the update.

I do have an other question:
I’d like to do some audio recording and the internal microphone doesn’t work well for anything more than a few centimetres away. My plan is to use an external microphone, does anyone have any experiences to share (with sailfish specific or with the fp2 in general)?

I did a summary in the previous alpha5 post :slight_smile: :

1 Like

Thanks a lot for the feedback folks! It is greatly appreciated!
This is what I had tried just before receiving your replies:
In order to start from a phone with Fairphone Open OS 18.04, Flashed (using command sh ‘sibon-18.04.1-manual-switcher’ from Fairphone’s website, because flashing the file from wiki.merproject would result in the phone not starting anymore.
Then, fastboot flash modem ./BP/NON-HLOS.bin after navigating in the directory of the unzipped ‘FP2-gms59-1.5.1-manual’ file
Then navigate to the directory fp2-sibon-18.04.1-manual-switcher\images and fastboot flash system system.img, fastboot flash recovery recovery.img, fastboot reboot
Turn on the phone, calibrate the proximity sensor, try the wifi antenna and calling, all ok.
Reboot in TWRP recovery, and hit install, navigate to the zip file, and install with MD5SUM check box not ticked and without wiping.
And it seems to have worked! All antennas, and preinstalled apps work. Very pretty OS btw!!!
Only, the phone will not turn off anymore. Powering off always result in reboot.
Also, in the jolla store, the search function doesn’t work, so I can’t find aptoide. I tried searching for it, and installing it from the website, but the installation doesn’t work.
Do you think I should reinstall the whole OS?

When you switch on the torch before shutdown, does that work?
At least for Android 7 or higher this workaround is needed to power off (otherwise it just reboots).

So I tried a couple of times, and it does not always work. actually, it worked 1 time out of 4.

Make sure the phone is not connected to USB or a charger, or the flashlight workaround might not work.
Maybe turn off Bluetooth, too.

Yep, usb was not connected, and bluetooth was off all the time.

If your question is how to install android apps, this is not (currently) possible because it’s a Community port, thus Alien Dalvik (licenced) is not available.

As far as I know, @mal is currently working on porting an Alien Dalvik substitute: anbox :slight_smile:

Well, my question is rather the following:
If the phone cannot power off, and the search function of the jolla store doesn’t work, can this be any related to what I have done during the installation?
Is there any way that I can solve these issues by installing sailfish OS differently? Maybe flashing different Android images?
If not, then I guess I should browse more forum pages…

In my opinion you installed correctly :slight_smile:

  • The phone that doesn’t power off with new camera is a general bug of FP2, and will/could not be solved in Sailfish before Fairphone team solve it and release a ( patch.
  • For the jolla store : AFAIK it’s normal that aptoid is not available without AlienDalvik.

-> Does any reasearch in the jolla store gives 0 result, or only aptoid is not found?

Any search, even with one letter, returns an empty list. Not even a message explaining that ‘no results were found’, not even ‘0 results’… Just the search bar with my keywords, and nothing below.

The interesting thing is that Ubuntu Touch doesn’t suffer from this bug (but it has other problems with the new camera module).

As I still need some Android-Apps, unfortunately depend on Alien Dalvik (which is not available for obvious reasons) or on Anbox. Therefore, I am even considering to exchange my FP2 with one of those XA2s :frowning: Is there any news whether @mal has made progress on the integration of Anbox? I hope so, because I am convinced that if he succeeds, I can give up the experiments with Sony, as everything he codes prove very stable so far :slightly_smiling_face:

Hello, my SMS problem was a layer 8 problem :frowning:

I have a multi sim contract and SMS only work on one of my sims. I had to switch the SMS usage form the first (main) sim to the second sim. Now it works as expected.


@mal: Hello mal i see a version at
Update as usual?

Many thanks again :slight_smile:

I was just about to make quick testing of the release image I built using testing repos and then make the announcement if it works as expected.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.