Sailfish OS alpha6 release

Sailfish OS alpha6 release is now ready. Installation and update instructions can be found at Adaptations/libhybris/Install SailfishOS for fp2 - Mer Wiki. Highlights of the new release:

  • Updated to Sailfish OS
  • Based on Android 6 (18.03 release)
  • Bluetooth LE support
  • Graphics performance improvements

Important notes for updating from Sailfish OS releases before (alpha5)! Please be very careful when during update about flashing the Android system.img. During update process Android system.img needs to be flashed right after updating Sailfish OS and shutting down the device. Do not flash system.img before Sailfish OS update.

Known issues:

  • Youtube videos crashes browser when seeking
  • Camera configuration detection for secondary (front) camera sometimes fails (only during camera module change, update or installation)
    • To solve the issue remove /etc/droid-cameradetect-module-main.conf and /etc/droid-cameradetect-module-front.conf and run “systemctl restart droid-cameradetect”
    • Repeat the previous instruction until both cameras work (configuration is at /etc/dconf/db/vendor.d/jolla-camera-hw.txt and the validity of resolutions for secondary camera can be checked also manually)

Currently updating using the OTA mechanism.

It does seem to hang during the “version --dup”:

[W] PackageKit::Transaction::parseError:803 - Transaction::parseError: unknown error “org.freedesktop.DBus.Error.InvalidArgs”

Broadcast message from systemd-journald@Sailfish (Sat 2018-04-21 20:02:57 CEST):

[31789]: Cannot mix incompatible Qt library (version 0x50603) with this library (version 0x50602)

Broadcast message from systemd-journald@Sailfish (Sat 2018-04-21 20:02:58 CEST):

[31803]: Cannot mix incompatible Qt library (version 0x50603) with this library (version 0x50602)

It’s been several minutes now. Is that normal?

Not good, I tried OTA via SSH so could monitor output and it downloaded packages but couldn’t apply them and was obviously going to go through nine (unsuccessful) attempts, which would have taken ages so had to abort process. Not unsurprisingly device would not then boot into Sailfish or Android for that matter, so had to download Open OS OTA version and re-install via TWRP. Device has has just booted into Sailfish now so going to have a look around.

That is not normal, maybe check journalctl output for hints what package could cause the issue. Maybe something you installed is built against wrong version or something and causes issues.

What did you see in output of version --dup? also in such cases checking journalctl output could be useful.

Started off with all the normal components being downloaded until reached 100% but when trying to install remained at 0% for every item and was it "status[0] beside each? Once it reached end of list it started “Attempt 2” and repeated the process again if this makes any sense.

Unfortunately device became very unresponsive with even difficulty accepting screen touch in TWRP and screen lit with horizontal lines when in “Fastboot mode”, so decided need to wipe it entirely at this point.

I just did an OTA update from a fresh install of alpha5 to alpha6 and I had no problems so it has to be some app(s) causing the upgrade issues.

I left the “version --dup” running for about an hour. It gave these “incompatible QT version” messages twice during that time.

Then I cancelled with ctrl+c and started the process again (as the instructions say) and then it said

Finished transaction (status=1, runtime=47119ms)
Finished transaction (status=1, runtime=3502ms)

NO UPDATES FOUND. Try again later.

So I continued with “sync” and then reboot. The system came up fine and shows “” as build information. :slight_smile:

In my case it could be something different. I did a backup with TWRP first. With that, my FP gets quite hot. Maybe I should’ve waited some time for the device to cool down before doing the upgrade.

TWRP does indeed cause the device to become very hot is used for a long time.

I updated my Sailfish OS to the new one via OTA, the upgrade worked like a charm.
Thank you @mal for your work :slight_smile:

| SailfishOS (Lapuanjoki)

I’ll soon give the OTA update a try, it’s the first time i’ll update the recently installed sailfish on my FP2. I do have a question:
I have two apps installed (GPSInfo and CodeReader, both from the jolla store), which indicate there is an update available, but then i try to update them it fails. On my jolla phone (running a 2.0.x release) i have the same apps installed without any problem. Is this something i should solve (probably by deinstalling the apps) or can i perform the update anyway?

That is not normal, if the installation or update of those apps fails, maybe you could try from terminal, first set password in Settings->Developer Mode and then devel-su zypper ref and devel-su zypper dup

Thanks for your help @mal. I ran zypper ref and zypper dup, after that the installed app list in the jolla store was empty. After a reboot (which did a nice and clean shutdown by the way) the list contained all my apps again, and all the apps indicate they are up to date.

So i guess i’m ready for the rest of the OTA update now :slight_smile:

1 Like

I’ve done the OTA update now, and had no problem whatsoever. Thanks for the good work @mal !

Does anyone have any experience using two SIMs in a FP2 running Sailfish? I’m using a single SIM now and would like to add a second. Problem is that i can’t go back due to SIM card size differences between phones, so i have to be sure it works before i make the change.

I think that both SIM slots are working under SailfishOS, someone will have to check, but, regarding the last part, you can always buy some adaptater :wink:

Again, thank you for all the work @mal :heart:

Just installed OTA update without any problems (alpha5 -> alpha6). Thanks @mal!


I’ve just added the 2nd SIM to my FP2 and it works perfectly. The only thing i can wish for is separate ringtones for both SIMs, so the ringtone indicates which SIM has been called.


@pa4wdh Thanks for the info.

Updated from (a clean) FP Open OS 18.04.1 without any problems!
So that works as well :wink: .
Now it is play time :slight_smile: .

Thanks for making this possible!