English

[ROM][UNOFFICIAL] LineageOS 16.0 for FP3

Yes, I flashed with TWRP - once.
Afterwards I’ve flashed with fastboot. I’ll try to wipe everything and then flash again. Maybe something was leftover by TWRP …

Hi @Max_S,
I flashed all slots with images with stock image 105 and went back to my own compiled images.
I did not recognize that I had to call “adb disable-verity” again. So it rebooted instantaneously. It took a while for me to figure out.
My phone still restarts before displaying the login screen. A new log is here:


Can you maybe have a look if you can see something useful in there?
I can’t really spot a difference.

I also tried to figure out why I do not see output on the uart (I see output from TWRP and the bootloader). As far as I can tell the kernel config and the boot parameters seem to be ok.
I even added debug and verbose as parameters in boot.img but that is maybe not useful for android kernels.

Hi, here are the latest news:

In fact, the serial console was turned off. I enabled it and now I also see messages on my UART.
Seems like the wcnss subsystem has a failure, then a watchdog hits and my phone gets restarted.

The log is again here:

Here are the changed lines:
kernel/fairphone/sdm632/arch/arm64/configs/fp3_stock_defconfig
CONFIG_SERIAL_MSM=y
CONFIG_SERIAL_MSM_CONSOLE=y

I think the main problem might be that /data is not being mounted but I dont know why:

[21:46:48:291] [   10.222542] DEBUG: pid: 488, tid: 488, name: app_process64  >>> /system/bin/app_process64 <<<
[21:46:48:291] [   10.222567] DEBUG: signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------
[21:46:48:291] [   10.222596] DEBUG: Abort message: 'Error creating cache dir /data/dalvik-cache/arm64 : No such file or directory'

Also plenty other /data related messages in the logcat, e.g.:

01-01 00:06:08.520   472   472 D vold    : Preparing: /data/system/users/0
01-01 00:06:08.521   472   472 E cutils  : Failed to mkdir(/data/system/users/0): No such file or directory
01-01 00:06:08.521   472   472 E vold    : Failed to prepare /data/system/users/0: No such file or directory
01-01 00:06:08.521   472   472 E vold    : Failed to prepare user 0 storage

There should be some mounted message for mmcblk0p62 (=userdata) close to the following (from comparing this with a stock boot):

[21:46:47:060] [    9.020521] EXT4-fs (mmcblk0p34): mounted filesystem with ordered data mode. Opts: barrier=1

Partition numbers can be found here.

Hi @_tmp, you were right. The data partition was not formated right. Turns out, I cleaned it with fastboot erase and not with TWRP to get rid of some strange effects. That left it probably unformated.
In the end also that was not the reason for the restarts. I removed the prima/wcnss Wlan drivers from the kernel. Now the watchdog does not timeout anymore and the restarts are gone. But now it never finishes booting (the Lineage circles never stop traversing my screen).

It seems like libarcsoft_low_light_shot.so is missing. I’ll upload some logs when I can’t resolve that.
EDIT: At least I can now access the half booted device with adb shell.

Update: I was able to make it boot completely - Yeah :sunny: !
Due to an unkown issue lots of files were missing in my vendor.img. I extracted the proprietary files again, deleted remains in the out folder & rebuilt.

5 Likes

Great to hear! Sorry, I didn’t had time the last days to check for that.
Did you also enable the WLAN drivers again?
Maybe did you have a chance to test LTE/phone functionality? Unfortunately I don’t have a nono-SIM available so it’s currently hard for me to try that :smile:

Yes I’ve enabled Wlan again and it works fine so far. In the end, the continuous reboot was probably also a side effect of an incomplete vendor image.
I have a nano sim that is not activated so far. I 'll try to activate it soon (I need to go to a post office for that).
I only have observed an additional app called “SIM Tool Kit” that wasn’t there before. The app obviously offers services from my cell-phone provider. So far I have never seen an app on a sim card…
Up to now, I just have observed one thing that is not working right: Once the screen is locked it stays black even when I unlock it. The phone is responsive just the backlight seems to be off.

Here is something probably related in logs:

adb logcat:
04-05 10:01:23.381 582 582 I light@2.0-servi: type=1400 audit(0.0:79): avc: denied { read write } for name="brightness" dev="sysfs" ino=30044 scontext=u:r:hal_light_default:s0 tcontext=u:object_r:sysfs:s0 tclass=file permissive=1

UART:
[23:01:23:114] [ 143.169488] type=1400 audit(1586120477.151:78): avc: denied { open } for pid=582 comm="light@2.0-servi" path="/sys/devices/platform/soc/1a00000.qcom,mdss_mdp/1a00000.qcom,mdss_mdp:qcom,mdss_fb_wfd/leds/lcd-backlight/brightness" dev="sysfs" ino=30044 scontext=u:r:hal_light_default:s0 tcontext=u:object_r:sysfs:s0 tclass=file permissive=1
[23:01:23:157] [ 143.178354] type=1400 audit(1586120483.381:79): avc: denied { read write } for pid=582 comm="light@2.0-servi" name="brightness" dev="sysfs" ino=30044 scontext=u:r:hal_light_default:s0 tcontext=u:object_r:sysfs:s0 tclass=file permissive=1

I was able to activate my nano sim card today. Unfortunately no phone related functionality seems to work so far. I’m absolutely clueless for what feature/issue I should watch out so I uploaded logfiles again.
Does somebody have an Idea what is going wrong here and can maybe share some insight?

Via adb:

Via dmesg:

Hi @Max_S, hi everyone !
Thank you so much for your work :slight_smile:
I really liked to join you and propose my help but i am not sure to have capabilities to do so…
I am also following the thread on /e/ ( i saw your post about gathering forces ) did you get any anwser about what you proposed ?

I have really low experienced in phones, just rooted an iPhone few years ago. But i have a geek nature and i’m used to following computing tutorial (understanding more or less what i am doing… )

So i feel pretty ready to try beta testing in case that it would be useful to your project ?
The /e/ dev said that they were looking only for experienced tester.
I don’t want to be a boulet (don’t know the translation of that one, but like a pain in the ass)

Hi there,

Thank you very much for this awesome work! I’ll be active on beta-testing :wink:

First feedback:

  • Flashing the ZIP from TWRP 3.3.1 does not work: says “Step 1/2, Step 2/2, Done”, but at reboot, stock Fairphone Android boots, nothing has changed
  • Flashing with fastboot (on both slots) seems to be going better, but first boot is stuck on LOS splash (it moves, but runs in circles ; I let it run for like 20 minutes just to make sure)

Fortunately I was able to flash stock ROM back thanks to this script.

What did i miss?

Unfortunately they keep their repository private until they publish a first version. It’s a pity, but they may have good reasons for doing it like that.

Please feel free to give it a try and report any issues. Or even try to build it yourself. However unfortunately I don’t have much time left at the moment to work on this and to provide support.

I expected that. Only did a quick try once and experienced same thing. Need to look into that more in detail.

If the LOS boot screen is shown, is already good. Did you do a factory reset with fastboot -w? Do you have logcat output (adb logcat)?

I also got the chance to try it today. It was working just fine for me. After some seconds it switched to LTE and incoming/outgoing calls worked as well. However I needed to notice that the ear speaker is not working. But maybe caused by proximity sensor which isn’t working as well :confounded: Will look into that.

LTE works now? it’s marked as “not working” in the summary here and on github… Would love to have an update on the LOS status for the FP3! :slight_smile:

1 Like

Yes, for me it was working fine today. Also I gave GPS a try few minutes ago (needed to step outside for that :nerd_face:). It’s also working fine.
However now the small things start to arise. E.g. for me the ear speaker was not working for calls.

1 Like

Actually factory reset through fastboot did not work, something that seemed related to partition type/block-size. But factory reset through LOS recovery did work, ROM 20200330 could boot completely, and I then flashed 20200413 and it’s working like a charm! Did not have a chance to test many things but fingerprint lock is working, Wi-Fi as well, etc. I’ll try to install several apps from f-droid to see what can go wrong. Unfortunately I don’t have nano-SIM yet so I cannot test LTE/phone, but everything that can be done through Wi-Fi, I’ll test it :slight_smile:

2 Likes

@david-guillot:
Good news, nice to hear.
Let us know how audio and video behave, I still expect some problems there. It is a good idea to always let adb logcat run while booting and capture the output to a file, e.g.

adb logcat | tee adb.logcat.txt

Assuming there is no private data stored on your device, you can share the output file on Gist .

2 Likes

Hi @Max_S, I have not been very successful lately. Strangely, all the images that I compile seem to have issues and stop somewhere in the middle of booting. I was able to make out seven files that were missing in my proprietary files compared to proprietary-files.txt. However, a new extract of the files solved that. But that did not help much I’m kind of stranded in a sort recovery mode (the Fairphone logo persists & I can login via adb shell).
In case that I’m doing something wrong, I am very keen to find out what!
I just saw that you added lineage_16_fp3_20200413.tgz, so I’ll try that and see what happens.

@michlx:
I assume you mean that the LineageOS logo persists? The Fairphone logo should no longer display if you are booting a LineageOS build.

You could try the following steps:

fastboot getvar current-slot # to confirm that you are still on your desired slot
# optionally fastboot -aa or fastboot -ab to always force the correct slot first
fastboot flash vbmeta vbmeta.img --disable-verity   --disable-verification # with a stock vbmeta.img
fastboot -w

Then reboot and see if things improve.

Regards,
D.

Hi @dk1978,

indeed, the Fairphone logo was persisting, it turned out to be recovery mode.
Both slots had an usuccessful state, that was probably the main cause.
I was able to fix that and finally boot the image that I compiled on Tuesday.
Very cool, the GSM modem works now and LTE is also there :slight_smile:

So far, I do not have TWRP installed, so the recovery mode was using my kernel, booted half and just displayed the Fairphone logo (I do not know if this is normal or not).
It took a while to find out what was going on (in the end adb get-state also said “recovery”).

After flashing vbmeta with --disable-verification I ran into the same problems as k4y0z here:


So I had to disable it again (and care about the slot success states).
Does it work for you?