Roaming icon not shown when connected to wifi


I have two SIM cards, SIM1 is a German one from Congstar and SIM2 a Spanish one from Yoigo.

Since I’m in Germany at present, my Spanish card is always in roaming. But the little “R” is not shown in the notification bar when I’m on wifi. only when I’m connected to the mobile internet with SIM1.

The problem is that I live very close to the French border and sometimes, even without crossing it, in some parts of the town, the connection switches to a French carrier. Now I’m afraid, I wouldn’t be aware of that, because the “R” isn’t always shown.

Enabling “always connect to preferred network” is not a real option for me, because I want and need roaming if I really go to France. I just would like to see it to keep incoming calls short.

Is the lacking “R” a bug or just a switched off option that I’m no able to find?