Roaming has to be activated to use data locally


I have a problem with my new FP2: roaming has to be activated so that I can use the data connection of the phone, even though I am in the right country. I also suffer from (irregular, and rare) interruption of roaming.

Could it be sim card related? Furthermore, the corresponding sim card does not seen to be identified, but otherwise works well (with this roaming issue though).

I have two sim cards in my phone (a drei austria, and a french one), both seem to work normally.

Any suggestions?

Many thanks,


How old are your SIM cards?

the austrian is ca. 2y old, and the french one less than a year old.

It is possible that at least the austrian SIM card is to old.

I had a similar roaming sim problem and have found a painful workaround. Background: UK sim run on giffgaff(O2) (sim 2) and Swedish sim on Telia (sim1).

Visited Sweden - switched to (native) Telia and phone jumped to 2G network, no 4G or data. Rebooted phone and got the message and other things happened to phone (wallpaper disappeared). Eventually restarted but without Telia acting like a native 4G phone.

Three solutions: 1: buy a new phone that roams properly, 2: revert to FP1 which worked perfectly in same environment or 3: swap sim cards around. This worked so Telia went into sim slot 2 and giffgaff into sim slot 1. Giffgaff roamed properly and telia behaved like a 4G phone.

On return to the UK the same thing happened as arrival in Sweden. Giffgaff dropped to 2G status and no data. I swapped over the sim cards and it worked perfectly.

As a regularly travel this is not a satisfactory solution as I think repeated removal of the case will lead to longer damage of the phone. In reality I think I will have to put my FP2 back in the box and wait for a fix and go back to FP1. Such a waste of money.

Perhaps changing only the settings of the 4G from one SIM to the other will do the trick.
Go to 'Settings’
go to 'More’
go to 'Mobile networks’
now you can see the two SIM
At one SIM the word ‘Perferred network type’ is black.
Tap on the black ‘Perferred network type’ and change it to 2G,
now you can choose 3/4 G for the other SIM
Hopefully by just switching the settings of the 2 and 3/4 G you get what you want.

1 Like


This is not so much related to the thread, but I was wondering about your set-up. I have the exact same set-up, giffgaff and telia simcards on a FP1. But I cannot get my telia to connect to the 3g network properly. It will only send and receive whatsapp texts, and nothing that demands any more data activity (loading webpages, sending images, loading emails etc). When I only use my Telia simcard it works perfectly.

I was in contact with telia support and they said it could be the sim not having a guarantee to work with the phone.

Have you experienced this at all with your FP1 set-up?

Hi Anna!

My problem was with the FP2. I previously used my FP1 in Sweden last year (Dec) with the same Telia sim card and it roamed properly and switched between the UK and Sweden fine. I am afraid I cannot tell you what the settings in the FP1 I used for Telia as I need to put the SIM card back into the FP1 and it is a fiddle with the FP2 opening up the back.

I think I just used the default setting from Telia for Android phone - they might have changed them since last year.

Not very helpful but defintely the FP1 worked fine last year between the UK and Sweden and roamed properly.

Good luck