Restoring TWRP Backup fails (Error 255) on a Xiaomi Mi9T

I have the same issue, the problem not eliminated.
I wipe everything as you described, then when i restore backed up data from OTG its not restored and error
extractTarFork() process ended with ERROR: 255
displayed again.
My Phone is Xiaomi Mi9T.
Please help me.

This is rather a forum for Fairphone owners.

You could try formatting the phone as said in this topic: 🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall, at the end, in the addendum.

See this part

Or just wipe the phone through advanced wipe and then format data.

1 Like

That’s right. I moved this here to the Discuss category where (almost) anything goes.

If your phone was/is encrypted, before you restore the data partition make sure that the same decryption method (= the same screen lock password/ PIN/ pattern) is set up again as it was at the time you backed up the data partition.

1 Like

I used this method but not worked.
I change my password to old. but twrp not restored. I get same error.
Then i delete all 999 (dual apps) in my backed up twrp images then it restored. but i lost all dual apps applications.
Is there any way to restore twrp backed up dual apps?

Dual Apps seems to be a vendor-specific feature not available in standard Android such as on Fairphones yet.

I don’t know why TWRP should care about what kind of stuff would be in a backup, apart from an available space problem while restoring perhaps, but I think probably at this point you should better ask in a Xiaomi forum.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.