Restore Backup made with an old TWRP-Version

Hey guys,

my brother wanted to update to the new lineage 15.1 yesterday. He made an backup of his phone with TWRP 3.0.2. Then he updated TWRP, got LOS 15.1 but wiped the phone before completely.

Now he has the Problem that he cannot restore the data Partition from his backup. But also reverting back to the old TWRP Version doesn’t help, as he is not able to access TWRP (with the power+volume button doesnt work) in order to go back to the old system and data.

Does anyone here have a clue what he could do to get back his data??

Thank you a lot!

What data does he expect do get back?
TWRP mainly does a backup of the current state of the installed OS. Everything in “Internal Storage” (pictures, downloads, etc.) is not backed up by TWRP, and there’s a clear warning about that while backing up the data partition.

If no other means of backup concerning Internal Storage were taken (e.g. copying everything to a PC via USB or syncing the data to the Cloud or to a PC), then this data is now lost after wiping the phone.

Anyway … I wouldn’t restore the data partition or any other OS part of one Android (Fairphone OS or Open OS) to a different Android (LineageOS), and also not from Android 6 (TWRP 3.0.2 implies Fairphone Open OS prior to 18.10.0) to Android 8.1 (LineageOS 15.1). Not a good idea conceptually.

Here’s a backup guide for future reference … ✏ Creating a backup of user data using TWRP community edition

If all else fails, a signed TWRP image can be booted without installing it …

Thank you for your answer.
We wanted to restore the data Partition as described in the guide that you posted. His OS before was LOS14.1, not the others you mentioned. On my phone it worked to Keep the data Partition when doing this update from LOS14.1–>LOS15.1

The Problem he has is that as he did the backup with TWRP 3.0.2 that apparently TWRP 3.2.3. cannot restore the data Partition of the backup made with the old Version.

Ok, TWRP 3.0.2 was part of Fairphone Open OS prior to 18.10.0, hence my assumption. The LineageOS install guide wants users to install the latest TWRP version, which wasn’t 3.0.2 anymore when LineageOS 14.1 for the Fairphone 2 came about. But … whatever works.

So, regardless of what might be a good idea or what might work in practice …

Is there an error message?

In what way doesn’t it work? OS boots instead? Bluescreen? Stuck at TWRP splash screen?
If the OS boots instead, make sure to keep Volume + pressed from before the phone starts/reboots right until TWRP appears.


Thank you for your help!

So the current problem is: He has LOS 15 running. As he wanted to restore the data partition which was not possible with the current TWRP version, he flashed the old version again… However, now he has the problem that he cannot access TWRP. When booting with Pressing Volume + the phone remains with the Fairphone logo and nothing happens. Trying with fastboot, the phone just boots normally into LOS.

Apparently even with the TWRP-App he cannot flash the latest version.

That’s what Fastboot mode looks like, and that would mean starting/rebooting the phone with Volume - pressed.
Are you really sure we are talking about Volume + here?

Can you access the phone with fastboot when the logo is shown (fastboot devices should not give an empty line)?

With the fastboot command (at least the one I have installed) you can only fastboot reboot the phone normally into the OS or fastboot reboot bootloader, which is Fastboot mode.
Normally, you would not get into recovery with fastboot alone (unless you fastboot boot a signed TWRP image like I mentioned earlier).

For reference, if you execute fastboot without anything else, it will give all its commands and options.

adb could reboot into recovery when the OS was booted and USB Debugging is activated in the developer settings, but rebooting into recovery automatically (without pressing Volume +) from the OS currently doesn’t work with the new camera installed (current workaround is to activate the torch before rebooting).

1 Like


I have a Problem with my fairphone.
I made an backup with twrp 3.0.2. from the last LOS 14 version.
Than i tryed to update to IOS 15.1.
That does not work so i updated TWRP to 3.2
After i installed IOS 15.1
But then I could not recover the data Form my old system. So i flashed again with twrp 3.0.2.

My Problem is now that i can not get into twrp.
Not with the startbutten+ Vol. + or- It stuck in the Fairphone screen.
Do you have an idea how to get my old data or how to flash the actuell TWRP cause now i could not update the IOS?

Thanks for your fast reply.
I try it tomorrow.

wenn i start the phone and it stuck in de start screen,
fastboot devicesgives me:

fc3f693 fastboot

So Fastboot mode works.
Now you could try to boot a signed TWRP image without having to flash it …

with a signed TWRP you mean the actuel version?

Thank you very much for your fast reply!

No, you need a specially signed image. Info is in the post I linked to.

oh my goodnes
its working. :smiley:
Thank you so much

can you tell me now if i can restore my old data from the old backup with an older TWRP version? :slight_smile:

I was so happy that the installation worked.
but I still can not start TWRP not with vol.+ and power.
Also not when i will install the actuel IOS version.

Have you tried with the booted TWRP image already?

Else … you could “Install” the TWRP 3.0.2 image file to “recovery” (not “boot”!) with the booted TWRP, you just have to switch the file viewer in TWRP to show IMGs instead of ZIPs, there’s a button for that.

Else … you could sign the TWRP 3.0.2 image yourself following the steps given in the post and then boot it.

Another thought … not getting into recovery even with Volume + pressed is not normal. If you install TWRP again and you can’t get into it this way, then perhaps remove the case from the phone and try without the case, a button could be stuck.

1 Like

i installed the TWRP 3.0.2 before but i not get into the TWRP.
so no i flashed the TWRP 3.2.3 like you told me but i also not get into it.

If it still doesn’t work without the case (no button stuck) … yet another thought:
If you have an SD card in the phone, remove it and try to get into recovery without it.

so without SD card and the button combination vol+ or - i still not get into the TWRP 3.2.3 which i flashde with the fastboot

If you start the phone with Volume + pressed and the Fairphone logo appears, does fastboot devices see the phone (“fc3f693 fastboot” just as before)?

And if you start the phone with Volume - pressed and the Fairphone logo appears, does fastboot devices see the phone (“fc3f693 fastboot” just as before)?