Replace GPS/compass chip(s)?

Would it be technically feasible by a hobbyist to replace those chips and maintain compatibility? My GPS is getting worse and worse (that’s actually surprising), and the compass is several degrees off, no matter how much I try to calibrate them. As for the GPS, I’m not sure if the chip or the antenna have more impact on ability to maintain a fix and/or accuracy. This is just a wild, random thought. Opinions?

AFAIK it isn’t possible. It’s on the core-module, and you can’t buy the chip separately anyway. Whether it’s technically feasible, I don’t know (and myself wouldn’t try).
Under what OS are you running? Did you try reinstalling it? Did you try installing another OS? Sometimes it helps.


Under what OS are you running?

FOS 19.11.2

Did you try reinstalling it?

No. I don’t even know how to do that, specially without losing any data on the phone.

Did you try installing another OS?

No. Several times I tried to install SailFishOS, but never got past the point of installing TWRP.

You can do a backup in TWRP (as explained in the #twrpbackup guide), reinstall the OS as explained here (or first you could try a #dic:factorydatareset) , shortly check if your issues are solved, and restore the Data partition only from your TWRP backup (in TWRP, tap on Restore, then tick only Data and untick the rest, and swipe to restore). Though be careful, your internal storage won’t be saved and you will lose it, except if you follow the #twrpstoragebackup tip, or if you just simply save it on your computer by copying the files and copy it back onto your phone after.
If you feel like all this is too complicated, you can either ask a #fairphoneangel that would be in your vicinity if he/she could help you (well, these times it’s a bit complicated with the pandemic), ask further questions that I or others will be glad to answer :slight_smile:, or forget about it.

Did you have any problems? At least you managed to install TWRP.

1 Like

…has the bug that only GPS satellites are used, no GLONASS, no Beidou. You could try one of the latest LOS builds, there the issue is solved and GPS works much better again.
For the upcoming FPOS based on Android 9 they have at least made a copy of the bug in the bug tracker but I don’t know the current status.

So before you start soldering at the core module check the software solutions first :slight_smile:

1 Like

Interesting. I was convinced that there was nothing we could do on the software side.

It doesn’t sound complicated, it’s just that I’m in a moment in my life where I don’t have enough free time in my hands to try all this in one go and rollback in case anything goes wrong. I’ll have to live with it until I get some more free time or Android9 comes out, I guess. Thanks for all the pointers.

1 Like

OK, it seems that an OS and/or change would solve the GPS, but what about the compass? Like i said, calibrating it doesn’t seem to help at all. The deviation is between 5 to 20 degrees.

Surprisingly enough it is not the that makes the change:

For the compass I recently had the impression that it was not too accurate in my phone, either (actually I had it once spinning around continuously as long as I was standing still), and also the recalibration wasn’t working quite well. However I didn’t put too much focus on that because for vehicle navigation the movement indicates the direction well enough most of the times.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.